<div dir="ltr">Thanks Petr. Updated patch attached.<br><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Sep 30, 2014 at 10:59 AM, Petr Viktorin <span dir="ltr"><<a href="mailto:pviktori@redhat.com" target="_blank">pviktori@redhat.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">On 09/30/2014 05:13 AM, Gabe Alford wrote:<br>
</span><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">
Updated patch to fix merge conflicts from recent changes.<br>
<br>
On Wed, Sep 24, 2014 at 8:34 PM, Gabe Alford <<a href="mailto:redhatrises@gmail.com" target="_blank">redhatrises@gmail.com</a><br></span><span class="">
<mailto:<a href="mailto:redhatrises@gmail.com" target="_blank">redhatrises@gmail.com</a>><u></u>> wrote:<br>
<br>
    Hello,<br>
<br>
    Patch for <a href="https://fedorahosted.org/freeipa/ticket/4399" target="_blank">https://fedorahosted.org/<u></u>freeipa/ticket/4399</a>. Let me know<br>
    if I missed any.<br>
<br>
    Thanks,<br>
<br>
    Gabe<br>
</span></blockquote>
<br>
Thanks for the patch, and sorry for the delay!<br>
<br>
ipaserver/tools/ipa-<u></u>upgradeconfig:<br>
The `filename` and `ca_file` aren't module-level constants; I think in this case they improve readability.<br>
The ticket calls for removing module-level lines like:<br>
    NSSWITCH_CONF = paths.NSSWITCH_CONF<br>
which are just silly, but assigning a name locally to a global constant is a valid thing to do -- even if the local name just says "the file we're working on now".<br>
<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
-        ca_file = paths.ALIAS_CACERT_ASC<br>
-        if os.path.exists(ca_file):<br>
+        if os.path.exists(paths.<u></u>SYSCONFIG_HTTPD):<br>
</blockquote>
<br>
Whoops!<br>
<br>
<br>
install/wsgi/plugins.py:<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
-PLUGINS_DIR = paths.IPA_JS_PLUGINS_DIR<br>
-<br>
</blockquote>
[...]<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
-    if not os.path.isdir(PLUGINS_DIR):<br>
+    if not os.path.isdir(paths.IPA_CA_<u></u>CSR):<br>
</blockquote>
<br>
Whoops too!<br>
<br>
<br>
ipaplatform/fedora/tasks.py:<br>
ipa-client/ipa-install/ipa-<u></u>client-install:<br>
ipaserver/install/dsinstance.<u></u>py:<br>
ipaserver/install/<u></u>httpinstance.py:<br>
Again, I'd not change the target_fname, filepath.<br>
<br>
<br>
ipapython/sysrestore.py:<br>
Again, `SYSRESTORE_PATH` describes better what we do with `paths.TMP`, so I'd prefer keeping it.<br>
<br>
<br>
ipaserver/install/<u></u>adtrustinstance.py:<br>
I don't think we want to convert the self.* to constants.<br>
<br>
<br>
ipaserver/install/certs.py:<br>
I'd leave NSS_DIR as it is, rather than lose the comment.<br>
<br>
<br>
ipapython/ipautil.py:<br>
ipaserver/install/ldapupdate.<u></u>py:<br>
ipalib/session.py:<br>
ipaserver/install/<u></u>bindinstance.py:<br>
SHARE_DIR, UPDATES_DIR, and krbccache_dir, NAMED_CONF (respectively) need to stay, unless you also replace them in everything that uses them.<br>
<br>
Be sure to run make-lint after doing these changes.<br>
<br>
<br>
I've rebased, and I made some of the changes as I went along the review. You can base another revision on the attached patch.<span class="HOEnZb"><font color="#888888"><br>
<br>
-- <br>
Petr³<br>
<br>
</font></span></blockquote></div><br></div></div>