[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Wheel module with trust doesn't work (?)



I sent this out a few days ago, but received no response.  Did others get it? 
Should I have sent it to another list instead?


When I put this line at the top of the 'su' PAM configuration:
	auth       sufficient  /lib/security/pam_wheel.so trust

I (in group wheel, gid=0), is prompted for a password when using su.

When I change it to this line:

	auth    sufficient  /lib/security/pam_wheel.so trust bug-workaround

(or any invalid keyword in place of bug-workaround), it works correctly (i.e.,
it doesn't prompt me for a password).  I think the non-"trust" case fails in a
similar way.

This looks like a bug to me.  Maybe it's not though (?)

I'm running Red Hat 5.0 with their latest patches.

	-- Alan Robertson
	   alanr@bell-labs.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []