[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

pam_ldap on Solaris 8



I am unable to get pam_ldap and OpenSSH working on Solaris 8.  

Here's the situation:
1. nss_ldap works fine (verified with id, etc.)
2. telnet works for an LDAP user.
3. OpenSSH v3.1p1 compiled '--with-pam'
4. OpenSSL v0.9.6c

I get the following in /var/adm/messages when attempting to login via
SSH:
[ID 487707 auth.error] load_modules: can not open module
/usr/lib/security/pam_ldap.so.1

I have tried compiling pam_ldap against different versions of openldap
(1.2.11 and 2.0.7).  

ldd against pam_ldap.so.1 returns all valid libraries... everything
looks fine.  Quite confusing.

If anyone can help, I'll buy you beer (or pizza, or whatever!)

-- 
Blake Barnett (bdb)  <blake.barnett@developonline.com>
Sr. Unix Administrator
DevelopOnline.com                 office: 480-377-6816

Learning is a skill, you get better at it with practice.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []