[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: audio on 600E with FC2 [Was: New kernel fails on thinkpad systems]




On Wed, 9 Jun 2004, William Penton wrote:


Satish Balay wrote:
I've briefly tried APM suspend - and audio on the 600E (with kernel
424) - and it appeared to work fine.

I tried upgrading to that exact same kernel (from the same site too) and the audio is still broken. What did I do wrong? In FC1 I managed to get sound up and running via an old page I found for Redhat6 and for the most part getting it to work was painless. I tried the same thing in FC2, didn't work anymore. If you dont mind would you please tell me how you achieved sound.

I'm assuming you are also using a 600E.


1. disable 'fast boot' in bios - otherwise the machine locks up on loading the sound module.
2. I have the following in /etc/modprobe.conf. (this is something i picked up from a google search)
[root localhost root]# cat /etc/modprobe.conf
alias usb-controller uhci-hcd

# ALSA portion
alias char-major-116 snd

alias snd-card-0 snd-cs4236 # You have to specify every damm paramter to get it working:
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388 irq=5 dma1=1 dma2=0


#alias /dev/mixer snd-mixer-oss
#alias /dev/dsp snd-pcm-oss
#alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
#options snd cards_limit=1

[root localhost root]# ------------------
3. I guess on reboot - use alsamixer to unmute (M)
4. use gnome-volume-control to crank up 'Volume, PCM, Out-gain" (perhaps others as well)
5. Test if I can play a .rm file with relaplayer https://helixcommunity.org/download.php/392/RealPlayer-0.3.0.120-gcc32-20040517.i586.rpm


Satish



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]