<html><head><style> body {height: 100%; color:#000000; font-size:12pt; font-family:Times New Roman;}</style></head><body>Folks,<br><br>I've been playing around with python-virtinst, with the primary goal of adding an initial round of LXC support to it.<br><br>While reading the code, I've found that "os_type" is quite misleading. This is already recognized and one example is this comment in virtinst/Guest.py:<br><br>    # GAH! - installer.os_type = "hvm" or "xen" (aka xen paravirt)<br>    #        guest.os_type     = "Solaris", "Windows", "Linux"<br>    # FIXME: We should really rename this property to something else,<br>    #        change it throughout the codebase for readability sake, but<br>    #        maintain back compat.<br><br>libvirt also refers to "ostype" all over the place, one example is in conf/capabilities.c:<br><br>    * virCapabilitiesAddGuest:<br>    * @caps: capabilities to extend<br>    * @ostype: guest operating system type ('hvm' or 'xen')<br><br>I feel that, even prior to adding LXC support to python-virtinst, I would benefit from learning more about the code while fixing this. I would like to have feedback on a couple of questions:<br><br>   * Should libvirt be targeted also? Would this have any impact on ABI/API stability?<br>   * Has a consensus been formed about alternative names for "ostype", "installer.os_type", "guest.os_type" and the like?<br><br>CR.<br><br><br><div>---<br>Cleber Rodrigues <<a href="mailto:crosa@redhat.com">crosa@redhat.com</a>><br>Solutions Architect - Red Hat, Inc.<br>Mobile: +55 61 9185.3454</div></body></html>