[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Porting the Psyche Install for Special Hardware



Michael, et al...

That was a great suggestion, and I tried it but unfortunately, it seems that
if APIC is compiled in, the installation process never makes it past the "Ok
Booting the kernel." message.

Is there any place where the process for the creation of the Setup kernel is
documented?  I am new to Anaconda / RH setup and am currently picking
through all the docs, but any pointing in the right direction would be
appreciated.

-Matt
mhowell anasazisoftware com

-----Original Message-----
From: Michael Fratoni
To: anaconda-devel-list redhat com
Sent: 2/7/03 7:02 PM
Subject: Re: Porting the Psyche Install for Special Hardware

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Friday 07 February 2003 07:25 pm, Matt Howell wrote:
> Brief History:
> I recently obtained a Toshiba Satellite 2435-S255 laptop and obviously
> envisioned RH 8 running on it.  Unfortunately, after initializing the
> installation, the box hangs at the "Booting the Kernel." message (no
> kernel version banner).  I was able to get Red Hat 7.0 (with the 2.2
> kernel) running on it and then I even got 2.4.18 to boot.
>
> Now, I would like to create a custom set of RH 8 install cds (using
> another box that is running 8.0) so that I can install psyche and have
> "restore CDs" for the future.
>
> What I have done so far:
> I was able to figure out that the problem rested in the APIC support
> included with the 2.4 kernel.  By removing this from the config and
> recompiling, I was able to get a kernel going that should work with
> 8.0.  In order to do this, I am speculating that the vmlinuz kernel
> included with the default 8.0 install will have to be replaced with a
> kernel that does not have APIC included.  I started researching the
> install process; Syslinux and Anaconda; and I browsed this mailing
list
> (anaconda-devel-list) in hopes that someone might have posted
> instructions as to how to create a new vmlinuz / initrd.img or at
least
> what options were used to create the stock one that is shipping with
> the installation?

Not to talk you out of what you are trying to do, but why not just
specify
that the kernel shouldn't attempt to use APIC?

Have you tried booting the installer with:
'linux noapic' ?

Worth a try, I'd think.

Hope that helps,
- -- 
- -Michael

pgp key:  http://www.tuxfan.homeip.net:8080/gpgkey.txt
Red Hat Linux 7.{2,3}|8.0 in 8M of RAM: http://www.rule-project.org/
- --
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE+RGU4n/07WoAb/SsRApUJAJ9dNaiKrXT+xr4LIvGNmfSJQnnH3ACeL8Op
Wj56EKtfZFW/enl8fVnmtYs=
=P0k2
-----END PGP SIGNATURE-----



_______________________________________________
Anaconda-devel-list mailing list
Anaconda-devel-list redhat com
https://listman.redhat.com/mailman/listinfo/anaconda-devel-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]