[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Redhat Install on Toshiba Satellite 2435-s255 [was: Porting the PsycheInstall for Special Hardware]



For those that are interested, I also recently purchased the Toshiba
Satellite 2435-s255 laptop. Awesome laptop for the money I spent. And,
I purchased the laptop knowing full well I'd have problems installing
RH 8.0 on it. However, after MANY attempts at installing RH 7.1, 7.3,
and 8.0--and Debian 3.0--I've come to learn RH's latest beta, RH 8.0.94
Phoebe, installs on this machine without a problem. It even recognized
all of the hardware, except the monitor--had to enter info manually.
Obviously RH changed the default kernel in the distro to include support
for acpi, as SuSe recently did. Awesome!

Laptop's running great! Now I'm happy!

Hope this helps!

Chris Shanahan

------------------------------------------------------------------------

Brief History:
I recently obtained a Toshiba Satellite 2435-S255 laptop and obviously
envisioned RH 8 running on it.  Unfortunately, after initializing the
installation, the box hangs at the "Booting the Kernel." message (no kernel
version banner).  I was able to get Red Hat 7.0 (with the 2.2 kernel)
running on it and then I even got 2.4.18 to boot.

Now, I would like to create a custom set of RH 8 install cds (using another
box that is running 8.0) so that I can install psyche and have "restore CDs"
for the future.

What I have done so far:
I was able to figure out that the problem rested in the APIC support
included with the 2.4 kernel.  By removing this from the config and
recompiling, I was able to get a kernel going that should work with 8.0.  In
order to do this, I am speculating that the vmlinuz kernel included with the
default 8.0 install will have to be replaced with a kernel that does not
have APIC included.  I started researching the install process; Syslinux and
Anaconda; and I browsed this mailing list (anaconda-devel-list) in hopes
that someone might have posted instructions as to how to create a new
vmlinuz / initrd.img or at least what options were used to create the stock
one that is shipping with the installation?

Incidentally, I already downloaded the beta 8.0.93 and tried that with the
same result (hung at "Booting the kernel.")

I apologize if this is the wrong list to be posting this to, but it seemed
the most reasonable.  Thank you for your time and consideration.

-Matt Howell
mhowell anasazisoftware com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]