[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

getfullcomps.py problems



I thought I might start to autogenerate comps dependencies, too, but getfullcomps.py doesn't quite work on my setup. Full output is included below. Can anyone explain this? And, yeah, I know I have unresolved dependencies, but I otherwise don't care too much about those, and should they provoke error messages like the one on the last line?

% /usr/share/comps-extras/getfullcomps.py comps.xml 9 i386
WARNING: Unable to find package efibootmgr. This may be an arch-specific package.
WARNING: Unable to find package elilo. This may be an arch-specific package.
CRITICAL ERROR: Unable to resolve dependency libgimp-1.2.so.0 for gimp-print-plugin
CRITICAL ERROR: Unable to resolve dependency libgimpui-1.2.so.0 for gimp-print-plugin
CRITICAL ERROR: Unable to resolve dependency libgimp-1.2.so.0 for gtkam-gimp
CRITICAL ERROR: Unable to resolve dependency libgimpui-1.2.so.0 for gtkam-gimp
CRITICAL ERROR: Unable to resolve dependency libgimp-1.2.so.0 for xsane-gimp
CRITICAL ERROR: Unable to resolve dependency libgimpui-1.2.so.0 for xsane-gimp
WARNING: Unable to find package AnotherLevel. This may be an arch-specific package.
WARNING: Unable to find package WindowMaker. This may be an arch-specific package.
CRITICAL ERROR: Unable to resolve dependency netscape-common for acroread-pluginWARNING: Unable to find package dosemu. This may be an arch-specific package.
WARNING: Unable to find package enlightenment. This may be an arch-specific package.
WARNING: Unable to find package fvwm. This may be an arch-specific package.
WARNING: Unable to find package fvwm-themes. This may be an arch-specific package.
WARNING: Unable to find package fvwm-themes-extra. This may be an arch-specific package.
WARNING: Unable to find package gnapster. This may be an arch-specific package.Traceback (most recent call last):
File "/usr/share/comps-extras/getfullcomps.py", line 188, in ?
main()
File "/usr/share/comps-extras/getfullcomps.py", line 104, in main
for req in hdr[rpm.RPMTAG_REQUIRENAME]:
TypeError: iteration over non-sequence






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]