[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Installing core system -- unresolved dependencies



Hello,

As an experiment, I am trying to install the core system in a separate directory, call it /newroot. I first create a new rpm database and then run the rpm against that database with --root specified as /newroot. As my package list I pass all the rpms specified in the group-id "core" of the comp.xml. However, this install fails with failed dependencies. Some packages that are part of the core system need packages that are not included in that core. My question is: is the set of packages in the core system not "self contained"? And what would be the correct way to install an absolute core system?

I tried one more thing.The three packages, namely, "basesystem", "filesystem", and "coreutils" need to be the first ones installed. I installed those first. Then I tried installing the rest of the packages from the core set. I got less errors, but there were still plenty. As an example, the "ash" package depends on "grep" which is not part of the core.

How does Anaconda install the absolute minimum set? Which file in the source does it?

Thank you.
Sergei Mikhailov





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]