[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: buildinstall error, is it fatal?



Mike Honeyfield wrote, around 10/05/2004 11:32 AM:
On Tue, 05 Oct 2004 08:17:37 -0700, Hal Wine <hal reactivity com> wrote:

I am using a fairly modifed version of anaconda version 7.3. Yes I
know its old, but thats what we are using :)

Right, that's of the same vintage as RHEL 2.1, so you may be seeing the same problem.


fwiw, with RHEL 2.1, we experienced intermitant failures of the sort
you're reporting. Retrying (as many as 4 times) would eventually produce
a working image.


Yeah, I have tried repeatedly. I did not count them, so I will try
your suggestion.

Actually, I set the loop to be up to 10, and it usually completed in (at most) 4 when it had problems. Often on the 2nd.


fwiw, I used a heuristic of whether the ${anacondaKernelVersion}BOOT/ directory existed at the end of the pass. If it did, I had a good iso:
temp=$(mktemp -d /tmp/$prog.$(id -un).XXXXXX)
anacondaKernelVersion=$(grep ^kernel-BOOT rpmlist-anaconda |
sed 's/kernel-BOOT-\(.*\).i386.rpm/\1/')
...
# it all worked heuristic:
[ $ec -eq 0 -a -d $temp/${anacondaKernelVersion}BOOT ]
ec=$?



...I never tracked it down, and it
seems to not happen under ES3....


Are you saying that buildinstall fucntions differently under the
anaconda version in ESver3 ?

It does roughly the same thing, but seems to have a few bugs/errors fixed. ES3 does use isolinux, so you don't have to cram drivers into floppy sized images. :) Moving is not trivial, as the comps file morphed into comps.xml with tons more metadata....


hth,
--Hal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]