[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

The campaign to do away with useless bugs!!!!!!

Hello list:
I have gone through some bugs and I have encountered that there are some issues that really must be addressed. I have basically seen that there are bugs that are already fixed and need to have their state changed. I have compiled a list to demonstrate my point. This is FAR from the total list of bugs that need to be revised for anaconda. I think that there are much more, the only thing that is needed is to squash them all (The ones that are squashable :). I haven't actually tested or changed them, just wanted to see what the list thought first before doing anything. So here is the list that I want to share with you.
Any comment is greatly appreciated.
(the *Issue* is the bug number, *description* is a part of what is shown in the bug description, *comments* are some personal comments and the *Proposed Action* is self explanatory

The campaign to do away with useless bugs!!!!!!
*Description: If a system has been installed from network the system-config-packages
should not try to read the package-list from /dev/cdrom but default to
the initial/previous installation source. the tool warns about missing installation source in
/dev/cdrom and cancels.

Comments: I have a fc6 running on my box, ran system-config-packages and
did not get the error message. (I did an nfs install).

Proposed Action: rawhide it, or currentrelease it to fc6.

Description:Then I chose Catalan (ca) as the language to use during the
installation. Then everything is in Catalan, but when it starts the
VNC server, all console text is in Spanish (es) (note: locale is ca_ES).

Comments: The person who filed the bug seems satisfied with the solution given.

Proposed Action: currentreleas it to fc6.

Description:Trying to setup a raid10 array in a kickstart install with:
raid / --fstype=ext3 --level=RAID10 --device=md2 raid.2 raid.3 raid.5 raid.6
but anaconda complains "RAID device requested without raid level"

Comments:On the bug its states that it is better to leave it as assigned and
close it when the issue is confirmed to be solved.  IMO I think it should be
currentreleased to avoid forgetting to close it. If the bug is not fixed and
the person is still interested it can always be reopened.

Proposed Action: keep an eye on it, if not issue is seen with in the fc7 release
                currentrelese it.
Description:It would be extremely useful if you could specify "@default" in the %packages section of a kickstart file to get the default package set that anaconda would install if you clicked through the package selection screen without modifying

Comments: Seems to be solved, some testing wouldn't hurt.

Proposed Action: rawhide it
Description:The installer's UI is fixed at 800x600. On a Dell 30" monitor, X will not think that small of a resolution is even supported. Attempting to start X at 800x600 will fail, and then we'll start at the native resolution; this will place the UI
in the top-left corner.

Comments: bugs been open for more than 4 months. I think its safe to say its fixed.

Proposed Action: rawhide it.
Description:hen clicking the final "next" before packages are physically installed on the system (fresh install, w/ FC extras extra repo added)a dialog pops up reminding the user that several "cds" are required even though the DVD install was used
(thus only one CD is needed which is IN the drive)

Comments: Its not that big of a bug, seems to be recently fixed.

Proposed Action: A little test and rawhide it.
Description:I tried to install FC6t3 from remote. I took an installed CentOS box, copied
vmlinuz and initrd.img to /boot and booted with arguments
"vnc vncpassword=**** lang=de_DE keymap=de resolution=800x600 ip=xxx netmask=xxx
gateway=xxx dns=xxx method=xxx"
The installation started as expected but while reading the package information, I got an error that anaconda is missing a package. I pushed the button to retry
and the bug report showed up.

Comments:Its apperantly fixed, its 6 months old and I don't think the user will comply with the testing requirements. ACTUALLY ALMOST ALL THE BEFOREMENTIONED BUGS NEED TESTING TO GIVE THEM THE GOAHEAD. (NO QE FOR FEDORA?) THE FIX WOULD

Proposed Action: a little test and rawhide it
There is a list of 21 fedora bugs that are MODIFIED and IMO, most of them,
need change of state. The only ones that I would leave in MODIFIED are the ones that are very recent and might still be an issue. But still I would keep an
eye on them so they don't get forgotten.
(Some of the I have already listed).

Description:Some genhdlist situation.

Comments: isn't genhdlist gone? in any case it was fixed in 2005-03-14

Proposed Action: I would cantfix it because its something that is not included
                in anaconda anymore.
Description:Clicking "Next" (or hitting ALT+N) too quickly (even as slowly as once per
second) will cause Anaconda to crash upon starting the actual installation

Comments: This is an issue from 2005-02-24, RHEL-3U4 and we are currently in RHEL-3U9

Proposed Action: currentrelease it to RHEL3U8
Description:need to add package group selection menu to installation dialogs
to allow user to select between "minimum", "LSB compliant", or "all"
package group for installation.

Comments: I'm pretty sure that the group selection in the installer is present.
         This issue is from 2004-06-15 18:09 EST

Proposed Action: currentrelease it to RHEL3U8
Description: network device ordering

Comments: Its an issue from 2006-03-02 15:58 EST, it is said that it is fixed.

Proposed Action: I would currentrelease it to RHEL4U4
Description:In particular, the "raid pv.20 --fstype
physical volume (LVM) --level=RAID1 raid.17 raid.18" line that was
created should have had the fstype quoted since it contains embedded

Comments:Its fixed and its an issue from 2005-06-07 15:31 EST
Proposed Action: currentrelease it.
Issue: 158370
Description:When specifying packages by name to be excluded in %packages (eg: '-mozilla')
anaconda only excludes the primary arch package

Comments: an issue from 2005-06-24 15:17 EST, It was not included in RHEL3U6 but the fix was still present in HEAD (so its must be present in RHEL5)

Proposed Action: currentrelease it.
Description:after supplying root password, anaconda popup's "...package..." and
the next is the Debug - request.

Comments: This one strange because it has a comment that was posted more than
         a year after it was said to be fixed.  The last comment does not
specify if the person did the test after of before RHEL4U1. Its an
         issue from 2006-08-18 17:26 EST.

Proposed Action: I would needinfo it. or better yet, a littl test and currentrelease it.
Description:Reliably reproduced a traceback on an rx2620 when autopartitioning a
cciss drives, that did not have previous paritions

Comments: Its a bug from 2005-02-15 12:13 EST.  A fix is mentioned and
         assured for RHEL4U1

Proposed Action: currentrelease it.
Description:Unneeded parameters are confusing since it is not clear what
should be entered and what happens if a value is given, e.g.
does the driver work with this values?

Comments: It is fixed for RHEL5

Proposed Action: a test and currentrelease it to RHEL5
Description:anaconda crashed while installing the packages. I only had selected the
software development selection, and did not customize package selection.

Comments: issue from 2006-10-12 10:13 EST and it is fixed.

Proposed Action: quick test and current release it
Description:something to do with the optimization of package installation.

Comments:This bug was first filed 2002-08-09 13:42 EST WOW.... 4 years latter
        it is revisited with new ways of optimizing the installation.
I would even say its not a bug. Its not an issue that breaks anaconda, its just that, according to the person who filed the bug, anaconda is
        resourse happy sometimes.  The last change was 2006-10-29 20:38 EST
        (a long time ago also).  its for fedora.

Proposed Action: I would notabug it.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]