[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Very weird harddisk stuff....



Hi guys,

sorry to keep bothering you ;)
but, I ran into another problem.

I had this once before, when I tried to use the latest anaconda on FC4, 
which failed miserably.
I therefore decided to upgrade my distro-building system + my distro-cd to 
FC6. Gotten far, but now constantly get that it could not initialize the 
SWAP partition.

I read some more (again) on kickstart config files, and decided to add a 
few --ondisk's...
That got me a little further: It now gives me:

"Specified nonexistent disk hda in clearpart command".

Which is weird, cause my HDD should be HDA.
It is a (P)ATA drive, on my primairy IDE channel, configed as master.
Now, I enter debug mode and type a "dmesg | grep hd".
It shows some SCSI device, sda, 80GB, which seems like my HDD.

However, if I run my kickstart for SD* (SATA drives), so with single 
SCSI/SATA drives (sda), it fails as well. Can not initialize swap.
Alt+F4 gives some crap, stack backtrace (cant read all of it)
something about mutex_lock, "but_mask is already holding lock", etc.

If I look at the dmesg again, I see all sorts of crap too:
ATA: abnora status 0x7F onj port x0010177...
ACPI error, createfield of length zero..... / method parse-execution failed, 
etc...

I also tried another disk, same result.

My questions are:
1. How to resolve the errors above?
2. Why does it see a drive that is supposed to be HDA as SDA??

Once again,
many many thanks!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]