[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F10 vs F11: %pre and zerombr/autopart


I have a kickstart setup that prepares the disks for a dual boot setup
with Windows. This setup requires a fixed sized & positioned partition
for the Windows world so I had to use sfdisk in %pre. This all worked
fine on F10.

Now with F11 I have the problem that after the installation the
system's first boot fails with mismatching sizes of the physical vs
superblock size of /dev/sda1, which is the /boot sector. The physical
size matches what I forced in with sfdisk.

I looks like the %pre script may run after the partitioning made by
anaconda, at least effectively.

My core question is how do I pass a partial partition setup to
anaconda? I need a certain non-linux partition to be at some specific
slot and some specific offset/size. Under F10 it worked to do

# System bootloader configuration
bootloader --location=mbr
# Partition clearing information
clearpart --linux
# Clear the Master Boot Record
# Allow anaconda to partition the system as needed
## 80887275 is rounded down to cylinder boundary of 80887338.
sfdisk -f /dev/sda << EOF
unit: sectors

/dev/sda1 : start=       63, size=   417627, Id=83
/dev/sda2 : start=   417690, size= 80469585, Id=8e
/dev/sda3 : start= 80887275, size= 75409047, Id= 7, bootable
/dev/sda4 : start=        0, size=        0, Id= 0

I also tried to comment out zerombr and/or autopart, but the problem
didn't go away. Furthermore it isn't 100% reproducible, I had 20
systems with identical hardware and some did properly install with a
rawhide/F11 setup of the 2nd June, but later rawhide/F11 setups would
have them all fail.

Axel.Thimm at ATrpms.net

Attachment: pgpPJkzX25JXX.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]