[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide build problems



On Mon, 2014-01-20 at 10:49 -0800, Adam Williamson wrote:

> 
> That's probably a good idea in general, because it's been my experience
> that you can't really rely on this kind of dependency being correctly
> stated. It is quite a large burden on packagers to maintain versioned
> dependencies to such a degree as to permit mixing of packages between
> releases even where it's viable (i.e. what you're doing), and it
> generally doesn't really happen.
> 
> It does seem like this specific instance is one it would be a good idea
> for GNOME/GTK folks to fix upstream, though.

Generally, unstable GTK+ depends on unstable GLib. In GTK+, we do bump
build requires in configure when we use new API in dependencies. So far,
we haven't folded these requirements into the pc files, but maybe that
is the prudent thing to do.

If anybody wants to take a crack at a patch for that, that would be
awesome! In any case, file an upstream bug, please.

Thanks, Matthias


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]