[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Promise PDC20267 problems



Hi
Sorry but I cant go through all the .config. Please help yourself with the
HOWTO and the past archives of this mailing list. If you still have
problems, someone on this list will answer if it has a specific
Subject: field

On Mon, 21 Apr 2003, Tiit Kaeeli wrote:

> On Sat, 12 Apr 2003, Murty Rompalli wrote:
> 
> > Do you have ext3 support built in the kernel ? Looks like you are using
> > initrd, is your Linux OS in the Promise FastTrak disks ?
> 
> Yes, my Linux resides on FastTrak. As mutch as I know, EXT3 support is
> included. (But I am not an experienced kernel configurator). So I included
> my .config file here, so You can verify this or any other problems.
> 
> 
> 
> > On Tue, 8 Apr 2003, Tiit Kaeeli wrote:
> >
> > > Hello,
> > >
> > > I am using Intel SE7500CW2 motherboard with on-board Promise PDC20267
> > > FastTrak 100 IDE Raid controller and trying to get 2.4.21-pre6 kernel
> up
> > > and running with it. System is RedHat 7.3. When I boot my new kernel,
> I
> > > get following errors after
> > >         Mounting root filesystem in read-write mode     [OK]
> > > and some more [OK]- s:
> > >
> > >         Finding module dependencies: execvp: Input/output error
> > >         EXT3-fs error (device ataraid(114,2)): read_inode_bitmap:
> Cannot
> > > read
> > >         inode bitmap - block_group=<number>
> > >
> > > Following many more errors like that with different block_group
> numbers
> > > (Sorry, theese are only notes on paper)
> > >
> > > I also tried RedHat kernel 2.4.20-8 and got the same errors. Kernel
> > > configuration file is kernel-2.4.20-i686-smp.config from RedHat
> 2.4.20-8
> > > source tree, only made modifications noted in Murty Rompalli-s Linux
> ATA
> > > RAID HOWTO. With older kernels I got lost IRQ errors, but according to
> > > /proc/pci PDC20267 is not sharing its IRQ with any other device. I
> found
> > > postings saying that there is a bug in kernels prior 2.4.21 causing
> this
> > > bahavior, so I decided to try 2.4.21
> > >
> > > my /etc/lilo.conf:
> > >
> > > prompt
> > > timeout=500
> > > default=2.4.18-3smp
> > > boot=/dev/sda
> > > map=/boot/map
> > > install=/boot/boot.b
> > > message=/boot/message
> > > lba32
> > >
> > > image=/boot/vmlinuz-2.4.18-3smp
> > >         label=2.4.18-3smp
> > >         initrd=/boot/initrd-2.4.18-3smp.img
> > >         read-only
> > >         root=/dev/sda2
> > >         append="hda=ide-scsi"
> > >
> > > image=/boot/vmlinuz-2.4.21-pre6
> > >         label=2.4.21-pre6
> > >         initrd=/boot/initrd-2.4.21-pre6.img
> > >         read-only
> > >         root=/dev/ataraid/d0p2
> > >         append="hda=ide-scsi"
> > >
> > > image=/boot/vmlinuz-2.4.20-8custom
> > >         label=2.4.20-8custom
> > >         initrd=/boot/initrd-2.4.20-8custom.img
> > >         read-only
> > >         root=/dev/ataraid/d0p2
> > >         append="hda=ide-scsi"
> > >
> > > Do I have to use append line? ATA RAID HOWTO talks about append line
> only
> > > when adding new non-os disks?
> > >
> > > Any ideas?
> > >
> > >
> > >
> > >
> > > --
> > >
> > > Tiit Kaeeli
> > > tiit_k ut ee
> > >
> > >
> > >
> > > _______________________________________________
> > > Ataraid-list mailing list
> > > Ataraid-list redhat com
> > > https://listman.redhat.com/mailman/listinfo/ataraid-list
> > >
> >
> >
> >
> > _______________________________________________
> > Ataraid-list mailing list
> > Ataraid-list redhat com
> > https://listman.redhat.com/mailman/listinfo/ataraid-list
> >
> 
> 
> 
> 
> Tiit Kaeeli
> tiit_k ut ee
> 
> 
> 





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]