[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fastrack 100 - kernel panic RedHat 7.3



Kamil,

I just set up a similar server using the fasttrak
driver instead of ataraid.  I cant help any with the
ataraid, but if you decide to try the fasttrak driver,
keep reading.

The RH7.3 default SMP kernel has a bug with the ext3
filesystem, and RH recommends upgrading the kernel.  I
was using the fasttrak.o driver supplied from promise,
but couldnt upgrade the kernel because the fasttrak
driver wont work. So the simplest thing to do was to
stick with the default 7.3 kernel and just downgrade
the filesystem from ext3 to ext2, thereby avoiding the
kernel bug altogether. Since doing this, the server
has been rock solid under heavy web and dns load.

The other FastTrak option is to try and compile the
recommended kernel from source and use the Fasttrak
"partial" source code to recompile a new fasttrak
driver yourself.  Promise sent me the code last week,
but I have not yet had the chance to try it yet,
however next week I am going to upgrade a server with
an SCB2 board, and will probably try this approach.

Promise has removed the source code they sent me last
week from their website, so I'm not too sure why they
did that, but I do have a copy available on my server.
If you want to try to compile your own fasttrak
driver, check out
http://www.realmsolutions.com/fasttrak.php to get the
source.

If you DO successfully get your SCB2 server running
smoothly with RH7.3, please give me a brief rundown of
what you did to get there.  Since I'm going to be
starting from scratch on an SCB2 next week, knowledge
of any pitfalls I can avoid would be great!

Good Luck,
Rob






--- "Kamil Staniucha - Ziaja Ltd."
<admin ziaja com pl> wrote:
> Hi !
>  
> I've got trouble with my Promise Fastrak 100 (20267)
> on Intel's SCB2
> motherboard and RH 7.3
> I've tried to follow Murty's howto to establish
> native Rad-1 (I have to
> upgrade my kernel to at least 2.4.19 or 2.4.20)
> but after kernel compilation and restart I've go
> "VFS kernel panic :
> unable to mount root FS on 72:01"
> Could anybody help me and give an advice what else
> should be set
> (/ataraid/d0p1 instead of /dev/sda1) beside
> lilo.conf
> I've changed fstab line 
> LABEL=/        /     ext3  default 1 1 
> to 
> /dev/ataraid/d0p1        /        ext3    default 1
> 1
> and tried with RH 7.3 built in lilo and after
> upgrade to lilo 22.3.4 and
> still had the same "kernel panic"
> I can't go to the next step with
> boot=/dev/ataraid/d0 .
>  
> Help please.
>  
> Thanks in advance.
>  
> Kamil
> 


__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]