[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

pdc202xx_new, ataraid, pdcraid



Hi all,

  Althought I read quite a lot of docs, and googled for a while I'm still
  puzzled.

  I have several server w/ onboard "Promise Technology, Inc.|PDC20276 IDE"
  from NEC. I see you can set in the BIOS to use this as ATA, or RAID. I
  interpret that when set as ATA I should be able to reach single disks
  while whe set as RAID, I should only see the array set from BIOS, correct?

  I also thought that pdc202xx_new should be my module, and in fact it loads
  correctly, and I see in the syslog:

   Jun 28 22:05:37 argo-cd kernel: PDC20276: IDE controller at PCI slot 02:0c.0
   Jun 28 22:05:37 argo-cd kernel: PDC20276: chipset revision 1
   Jun 28 22:05:37 argo-cd kernel: PDC20276: not 100%% native mode: will
       probe irqs later
   Jun 28 22:05:37 argo-cd kernel:     ide2: BM-DMA at 0xa800-0xa807, BIOS 
       settings: hde:pio, hdf:pio
   Jun 28 22:05:37 argo-cd kernel:     ide3: BM-DMA at 0xa808-0xa80f, BIOS 
       settings: hdg:pio, hdh:pio

  and from here it seems I should see 
     /dev/hde
     /dev/hdf
     /dev/hdg
     /dev/hdh

  What does "will probe irqs later" means?

  but how can I fdisk them? I use devfs and no devices appear, I could create
  devices bus how should I create them? (I already added all devices
  /dev/ataraid/*, thought they are not used here)

  If I now try to unload the module, it says:

    root argo-cd root # modprobe -r pdc202xx_new 
    pdc202xx_new: Device or resource busy
  What is it doing?

  If I modprobe ataraid it just work but:


  root argo-cd root # modprobe pdcraid 
  /lib/modules/2.4.21-p3/kernel/drivers/ide/raid/pdcraid.o: init_module: No such device
  Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
  /lib/modules/2.4.21-p3/kernel/drivers/ide/raid/pdcraid.o: insmod /lib/modules/2.4.21-p3/kernel/drivers/ide/raid/pdcraid.o failed
  /lib/modules/2.4.21-p3/kernel/drivers/ide/raid/pdcraid.o: insmod pdcraid failed

  I don't really understand when I need ataraid/pdraid. Should I need them if
  I want to use md-tools linux RAID1 or (as I suspect) I only need it if I
  want to use hardware raid?

  NOTE: it fails in both cases: ATA or RAID1 settings.

  Thanks in advance!


  sandro
  *:-)


-- 
Sandro Dentella  *:-)
e-mail: sandro dentella tin it 
http://www.tksql.org                    TkSQL Home page - My GPL work




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]