Promise PDC20265 RAID over kernels 2.4 ro 2.6 (Desesperation)

Borrajudo Carajudo borrajax_listas at
Fri Feb 20 18:56:36 UTC 2004

Hello. Good evening from Spain.

This is my first message to the list, and is consequence of a newie's
exasperation that doesn't know what's happening in his computer.

I've got a Gigabyte 7DXR+ motherboard, with an integrated RAID controller
Promise Ultra Lite 100. I think that the controller's model is the PDC20265,
and I configured it as RAID-0 (stripping). The idea, in fact, is to be able
to boot from the RAID (I mean, without any hard disks on the "usual" IDEs.
Only CD-Roms over ide's 1 and 2). Well...I got a weird problem. It's weird
at first seen, and exasperating after some days trying to fix the problem
without success.

With Kernel 2.4.18 -->
    I install Linux perfectly. The RAID hard disk is perfectly seen by
Cfdisk. I partition it, I make my Ext3 partitions perfectly, I make a
gorgeous swap partition, I select every module that could remember to
"RAID", I make a floppy "rescue disk", I put my LiLO in the mbr, I reboot
and... ¡Oh surprise!, the system gets hanged up when it is going to
recognize the disks (just before recognizing disks over ide1 and ide2). But,
the weird think comes when I boot from the floppy. If I do  that, the system
works properly, and I have no problems, all the partitions are done, all the
data are there, and I don't have any problem. I've seen that there is an
option for partitions called "linux raid autodetect". At first, I didn't had
my partitions that way, but I converted them to this (with Cfdisk) and the
problem is still there (I didn't see any changes).

The fact is that the "hanging up point", in principle, has no relation with
the floppy, because if I boot from the floppy disk, it reads the "Linux.bin"
image from the floppy, yes, but it stops reading the floppy before the
hanging up point. I mean, is like if that "frosting point" had no relation
with the fact of booting from floppy or from hdd. Obviously, that's
impossible, because booting from floppy the system works nice, but gets
frozen booting from hdd. I've been reading HowTos, and many other things,
and I reached the conclusion that it could be a Lilo's problem, but I've
tried many things, and many options in Lilo and the problem is still the
same. I tried to put the append "ide2=0x..., ide3=..." that I saw in many
places, and nothing. I tried to change the partitions from /dev/ataraid/d0pX
to /dev/mdX, and even to /dev/hde, and noooooothing. The same problem. And
when I say "the same", I mean "the same": I can't see any changes on the
behabvior of the computer.

With Kernel 2.6.2 ->
        I compile it with every options that could remember (even from far
away) to "RAID", even some things of SCSIs. Of course, I load the PDC20265
controller, and even the PDC20276¿? (not sure about wich other, but other
PDC20xxx). Everything I found that could have relationship with RAID, I got

I compile the kernel, I have a beautiful, free of errors bzImage, I compile
my problems, I change my lilo to "see" the kernel 2.6, I reboot
and... Plaf!!: Kernel Panic. Unable to mount VFS. I think he also says that
he's unable to find something bootable in the 7200 sector (of something like
that), and he also says that wants something correct for the "root=" option.

    The root option in my lilo is /dev/ataraid/d0p9, that is my / partition,
partition that is perfectly loaded when I boot from floppy.

    Well... at least with this kernel I get an error message XD. Seriously:
I've tried to put everything in Lilo: I tried putting in the root option
everything; from /dev/ataraid/d0p9 to /dev/md0, /dev/md1, md9... to
configure manually the boot sector (I got the 63), saying that
disk=/dev/ataraid/d0, and even /dev/hde, and noooooooooooooothing.

    I've been looking trough internet for days, reading hundred of  HowTos,
and nothing. What if I used grub? It would help?

    Please... Anyone has had a similar problem?. Any ideas?. It would be
very helpful. It would be helpful for my walls too, because in two or three
days, if I can't fix the problem, I'm going to butt them.

    Thank you in advance,

More information about the Ataraid-list mailing list