DMRaid mkinitrd

Mark Wormgoor mark at
Tue Oct 12 18:12:20 UTC 2004


Nope.  My hacked Anaconda didn't add an alias scsi_hostadapter sata_sil to
/etc/modprobe.conf, so my initrd did not include the libata or sata_sil
modules.  That suddenly came to me this morning ;-)

Anyway, I'm typing this from a running Fedora-devel system just booted
using dmraid.  I only had to do some small hacks to mkinitrd and
rc.sysinit to get it to boot.  Unfortunately, my rootdev is now hardcoded
into mkinitrd.  I'm going to try and figure out if I can improve on that.

Also, I need to look at my Anaconda hack to see if I can get it to
properly update modprobe.conf.

Then, I will try Erik's patches to lilo and see if I can ditch my FC1
installation after FC3 final comes out (I still need FC1 to run lilo after
every update to initrd; wouldn't grub be nice now).

Kind regards,


Erik Agsjö said:
> Is there any way you can get strace onto your initrd image? This was
> really helpful for me when I didn't get any useful output from the
> tools. Also, does any "dm-X" nodes appear under /sys/block when dmraid
> is run?
> /Erik
> On Mon, 2004-10-11 at 22:04, Mark Wormgoor wrote:
>> Hi,
>> After spending a lot of the weekend with Anaconda, I managed to install
>> Fedora devel (Rawhide) on my machine with a SiI3112 SATA RAID-0 set
>> (already running FC-1 with medley.o).  Patch is available upon request.
>> My next step is to get it to boot without too much hacking to the
>> current mkinitrd script.  But... I'm not having a lot of success.  What
>> the script does is:
>> - run nash
>> - mount proc
>> - mount sysfs
>> - start udev
>> Then, I let it run dmraid -ay.  I know dmraid works, because I used it
>> in Anaconda to install. But, dmraid just exits with an error with no
>> real error message (just return code = 1).  And, the devices are not
>> there under /dev/mapper.  I tried the static binary from the static rc4
>> rpm and I tried a self compiled binary with enable-mini.  It doesn't
>> make any difference.
>> I even copied a static busybox into the initrd to troubleshoot, but
>> nothing I do helps.  What is going on?
>> Erik, how did you get it to work?
>> BTW, next step is lilo; I am still using lilo under FC1, since that
>> works, but after getting initrd to work, I will try Erik's patch next.
>> Kind regards,
>> Mark
> _______________________________________________
> Ataraid-list mailing list
> Ataraid-list at

* |\    /|      |  /|  /       Mark Wormgoor                  *
* | \  / |      | / | /        mailto:mark at       *
* |  \/  |ark   |/  |/ormgoor  *

More information about the Ataraid-list mailing list