[PATCH] very rough cut of adaptec hostraid support for dmraid

Darrick J. Wong djwong at us.ibm.com
Thu Dec 15 00:29:24 UTC 2005


Below is a very preliminary patch to enable Adaptec HostRAID support in
dmraid.  I've been able to configure RAID 0 and 1 arrays on an IBM x226,
though I've not had a chance to test it on anything else, such as the
SATA HostRAID machine that I have sitting nearby.  I'm sending this
patch to this list for review and feedback; at this stage, this patch
should not be used by anyone with any valuable data at all.

So far, the only testing it's seen is an ad-hoc setup wherein I loaded
the a320raid module in SLES9, made a filesystem on the RAID, filled it
up with assorted junk, rebooted into to 2.6.14, ran dmraid -ay, and then
compared what was on the RAID with the originals.  That worked, so I
wrote some data, rebooted back into SLES9, and compared the filesystem
contents under a320raid.  That worked too, so off goes the patch.

Note that there's quite a bit missing right now--it can't write
metadata, spares are totally ignored, and nested RAID setups (RAID10 in
particular) are not implemented.  Yet.  Indeed, I'm only interested in
making sure that I'm not barking up the wrong tree with this. :)

Questions?  Comments?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: asr_1.patch
Type: text/x-patch
Size: 35842 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/ataraid-list/attachments/20051214/77806769/attachment.bin>

More information about the Ataraid-list mailing list