Debian and dmraid... is it possible to install?

Albert Dengg a_d at
Fri Jul 22 08:43:29 UTC 2005

On Thu, 21 Jul 2005 01:24:49 +0200
"Emiliano Esposito" <skywalk3r at> wrote:

> Greetings to all!
> First of all, I hope not being OT nor asking something already asked
> (I've searched much for this though...).
> In short: I need to install Debian (via cds or net-install) on an asus
> a7n8x with silicon image 3112 medley RAID, two maxtor 160 gb sata
> disks.
> I have Windows and a Gentoo up and working, but now I need Debian. The
> latest distro (sarge stable) won't recognize the array with kernel
> 2.6.8 nor with 2.4.27. 
> This is what I tried to do:
> - booted gentoo, and copied dmraid and udev (+ libs) onto a floppy
> - booted minimally debian from cd
> - mounted the floppy and copied all on the fly onto the ramdisk
> Then various (different) attempts:
> - configure md via debian installer
> - configure LVM as above
> - modprobe dm-mod
> ...and then:
> udev
> dmraid -ay
> Doing this I finally get all the partitions shown into
> /dev/mapper/sil_xxx as with Gentoo, I can mount and format them, but
> this is the error when I try to install the base system:
> [installing kernel-2.6.8-386.deb]
> /usr/sbin/mkinitrd: /dev/mapper/sil_xxxx9 is not a valid block device.
> [error message]
> What can I do now?? What could this error mean? It is a fatal error
> that won't quit the installation but would loop to "install base
> system".
> Thank you for reading! ;)
> Regards
> Emiliano Esposito
well i don't know if it is possible with d-i, but doing a chroot install
should be possible
(you already seem to have a bootloader installed, so there should be no
like discribed here for example
(ok, it is for woody, but that is just a matter of s/woody/sarge/)+
(should be possible from gentoo to....)

i have not tried it to set up a dmraid setup
(i have not tried that at all-my only ataraid install used a 2.4

but it should work with some customizing i think


Albert Dengg <a_d at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the Ataraid-list mailing list