Past End Of Device

John Anderson john_anderson_ii at
Sat Apr 8 03:40:46 UTC 2006

Hello all! 

I just bought a brand new box with an EVGA nForce4 mainboard (Model 
Techsheet: .  I setup 
the nvraid in the BIOS. Then installed Window XP.  I know, installing 
windows is a dirty thing to do, but I was dying to play Oblivion on my 
new box!  After my Oblivion fix I then started to install a homebrew 
X86_64 distro that I've been using for a while (based on the X86_64 
multilib LFS project).

I ran dmraid -tay and I got:  nvidia_afaafcdh: 0 488397166 mirror core 2 
64 nosync 2 /dev/sda 0 /dev/sdb 0
I ran dmraid -s and I got:  Set name : nvidia_afaafcdh size : 488397166 
stride : 128 type : mirror status : ok subsets: 0 devs : 2 spares : 0
I ran dmraid -ay and I got: 
    attempt to access beyond end of device
    sda: rw=0, want=488398912, limit=488397168
    attempt to access beyond end of device
    rw=1, want=488398912, limit=488397168

At this point, I knew something was wrong, but I figured, "It's a brand 
new installation with no data, what the hell.", so I started playing 
with it.  /dev/dm-{0,1,2} was present as well as the /dev/mapper/ files, 
so I installed grub on the raid then mounted the drives and started 
installing software packes on them.  After writing to the raid for a 
while  I got a kernel paging request oops from kmirrord.  I have the 
full text of the oops if anyone is interested, just ask me to send it.

I'm guessing that the nvraid on this board is too new to be supported.  
If you guys don't think that's the problem or if I'm just being dense 
and overlooking something please let me know.

Here's a list of revelant software installed:
libc: 2.3.90
dmraid: 1.0.0.rc10
device-mapper: cvs-latest as of (7 Apr 2006 15:00:00)

I've installed the kernel without the GRSecurity patches just to make 
sure that wasn't the problem, but it didn't change anything. I also have 
a tarball of the metadata from dmraid -rD.  I'm not sure if you guys 
want me to send that tarball to the list so we can have fun replicating 
all 397 bytes of it to everyone's inbox, or if you guys want me to 
upload it somewhere, etc.

I'm a horrible C programmer.  A regular self-taught dirty hacker, but 
I'll try my hand at building the proper metadata for this fakeraid.  
However, my way of fixing the problem is almost guarunteed to NOT be the 
RIGHT way of fixing the problem :-)

John A.

More information about the Ataraid-list mailing list