Poorer performance with Raid0 then without?

Listbox listbox at hymerfania.com
Sun Dec 31 07:07:48 UTC 2006

Hi folks!
I have been trying to use a 
 RAID bus controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host
Controller (rev 02)
to create a  RAID0  workspace for MythTV, but it's not working right....
I have two Seagate 160gb drives in a RAID 0 array on an SiI0680 PCI 
ATA raid controller. I formatted an XFS filesystem on
and set mythbackend to use it. ( My DVB card is a DviCO 
Fusion Gold 3,( Conexant CX23880).)
When I watch live MythTV, I get terrible artifacts on digital TV, and slow 
frame rates on analog. When I reset mythbackend to use a ext3 
partition on a single drive ( /dev/hdc1 ), performance is acceptable.

The RAID devices are hde and hdg, the/ partition is hdc.... to me this looks
like all my physical drives give comparable throughput. This is what hdparm

 Timing cached reads:   1668 MB in  2.00 seconds = 834.10 MB/sec
 Timing buffered disk reads:   88 MB in  3.05 seconds =  28.87 MB/sec

 Timing cached reads:   1680 MB in  2.00 seconds = 838.49 MB/sec
 Timing buffered disk reads:  168 MB in  3.03 seconds =  55.46 MB/sec

 Timing cached reads:   1688 MB in  2.00 seconds = 843.57 MB/sec
 Timing buffered disk reads:  164 MB in  3.00 seconds =  54.59 MB/sec

 Timing cached reads:   1696 MB in  2.00 seconds = 846.68 MB/sec
 Timing buffered disk reads:  162 MB in  3.03 seconds =  53.45 MB/sec

I also tried upping the PCI latency of the RAID card with 
        setpci -v -s 01:07.0 latency_timer=B0 # PCI0680 Ultra ATA-133 Host
But this had no effect. The DVB card has a latency of 32(decimal).

So, given the same hardware throughput, I would expect better performance
with the XFS+RAID setup. This is not the case. I went to considerable
trouble to get the RAID and XFS working on my Fedora 5 system, and it's
pretty discouraging to see that it actually 
degrades instead of enhances performance.

I just reformatted with ext3, and tried again, and got the same degradation.
It's looking like the RAID is the problem, but I do not,NOT,NOT! want to
un-stripe the disks. 

What else to try?

More information about the Ataraid-list mailing list