[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Two isw RAID1 arrays



Hi,

I have a machine with 4 SATA disks, configured in two separate fakeraids.
While the hardware is detected correctly, I cannot get the system to make
the device files for the partitions.

I tried dmraid rc14, rc15 and a patched rc15 from Debian Sid. With the
newer versions the RAID isn't even detected. I know there are various
patches floating around but it's unknown which ones are good. So here is
some output from rc14. Kernel version is 2.6.28.9

# dmraid -r
/dev/sdd: isw, "isw_dhhidegdgf", GROUP, ok, 488397166 sectors, data@ 0
/dev/sdc: isw, "isw_dhhidegdgf", GROUP, ok, 488397166 sectors, data@ 0
/dev/sdb: isw, "isw_dejhhehaec", GROUP, ok, 488397166 sectors, data@ 0
/dev/sda: isw, "isw_dejhhehaec", GROUP, ok, 488397166 sectors, data@ 0

# dmraid -ay -vvv
WARN: locking /var/lock/dmraid/.lock
NOTICE: /dev/sdd: asr     discovering
...
NOTICE: /dev/sda: isw metadata discovered
...

NOTICE: added /dev/sdd to RAID set "isw_dhhidegdgf"
NOTICE: added /dev/sdc to RAID set "isw_dhhidegdgf"
NOTICE: added /dev/sdb to RAID set "isw_dejhhehaec"
NOTICE: added /dev/sda to RAID set "isw_dejhhehaec"
RAID set "isw_dhhidegdgf_Volume1" already active
INFO: Activating GROUP RAID set "isw_dhhidegdgf"
RAID set "isw_dejhhehaec_Volume0" already active
INFO: Activating GROUP RAID set "isw_dejhhehaec"
NOTICE: discovering partitions on "isw_dhhidegdgf_Volume1"
NOTICE: /dev/mapper/isw_dhhidegdgf_Volume1: dos     discovering
NOTICE: /dev/mapper/isw_dhhidegdgf_Volume1: dos metadata discovered
NOTICE: created partitioned RAID set(s) for
/dev/mapper/isw_dhhidegdgf_Volume1
INFO: Activating partition RAID set "isw_dhhidegdgf_Volume15"
WARN: unlocking /var/lock/dmraid/.lock


# ls -l /dev/mapper
crw-r--r--    1 root     root      10,  63 May 24  2005 control
brw-------    1 root     root     254,   0 Apr 21 13:13
isw_dejhhehaec_Volume0
brw-------    1 root     root     254,   1 Apr 21 13:13
isw_dhhidegdgf_Volume1
brw-------    1 root     root     254,   5 Apr 21 13:37
isw_dhhidegdgf_Volume15

After activating, there is only one partition detected, but there should
be 3, as can be seen from the fdisk output below. The first raid has a
single primary partition, the second one a singe logical partition. Using
libdevmapper 1.02 or 1.02.1 doesn't make a difference.

# fdisk -l /dev/mapper/isw_dejhhehaec_Volume0

Disk /dev/mapper/isw_dejhhehaec_Volume0: 250.0 GB, 250056015872 bytes
255 heads, 63 sectors/track, 30400 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

                              Device Boot    Start       End    Blocks   Id
System
/dev/mapper/isw_dejhhehaec_Volume0p1   *           1       30400   244187968+
7  HPFS/NTFS

# fdisk -l /dev/mapper/isw_dhhidegdgf_Volume1

Disk /dev/mapper/isw_dhhidegdgf_Volume1: 250.0 GB, 250056015872 bytes
255 heads, 63 sectors/track, 30400 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

                              Device Boot    Start       End    Blocks   Id
System
/dev/mapper/isw_dhhidegdgf_Volume1p1               2       30400   244179967+
f  Win95 Ext'd (LBA)
/dev/mapper/isw_dhhidegdgf_Volume1p5               2       30400   244179936
7  HPFS/NTFS


I tried to do "dmraid -ay" for each RAID separately but this didn't
help either.

There's probably some information missing, tell me what you need.

Thanks,
hjb
-- 
Pro-Linux - Germany's largest volunteer Linux support site
http://www.pro-linux.de/          Public Key ID 0x3DDBDDEA

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]