Two isw RAID1 arrays

Hans-Joachim Baader hjb at
Mon May 4 05:35:11 UTC 2009


> have you tried with -p in order prevent dmraid from partition activation
> and used kpartx to activate them yet to see, if that makes any diffrence
> for you ?

as previously said, "kpartx -l" worked, but "kpartx -a" gave errors.
Here they are:

device-mapper: create ioctl failed: No such device or address
device-mapper: reload ioctl failed: Invalid argument

Also, I attach the strace output for the command.

Meanwhile I booted with Knoppix 5.1 and grml 1.1 to examine the situation.
Both contain drmaid rc13 and Device-Mapper 4.10.0 (or 4.11.0). Both were able
to initialize the two RAIDs correctly with partitions. I had to activate
them one after the other, a simple "dmraid -ay" didn't work (IIRC it
activated only one RAID). But it worked. So I integrated dmraid rc13 in
my normal environment. Again, it failed to initialize the partitions.
The version of Device-Mapper there is 4.14.0 (Kernel So it
may be a problem in the kernel. Should I file a bug, perhaps even a

My environment is a quite restricted one and contains an old glibc (2.3.2
or so). Does that matter?

Pro-Linux - Germany's largest volunteer Linux support site          Public Key ID 0x3DDBDDEA
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kpartx.trace.bz2
Type: application/octet-stream
Size: 2487 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the Ataraid-list mailing list