dmraid problem 1.0.0.rc16 doesn't work, rc15 works fine

Heinz Mauelshagen heinzm at
Mon Nov 15 11:52:28 UTC 2010

On Sat, 2010-11-13 at 12:38 -0900, Stephen S wrote:
> Sir:

Hi Steven.

>      I am writing you because I found your name in a dmraid readme file.
>      I am presently running a system with a Gigabyte motherboard with both AMD and Gigabyte controllers.  I have a dual boot with Windows 7 and Linux and I'm running a Raid 1 array plus a single disk on the AMD controller set to IDE.
>       When I run Karmic (ubuntu 9.10) -- it works fine.  The dmraid version is listed as 
> dmraid version:		1.0.0.rc15 (2008-09-17) shared 
> dmraid library version:	1.0.0.rc15 (2008.09.17)
> device-mapper version:	unknown
> But when I run Maverick (ubuntu 10.10), nothing works.  The dmraid version is listed as
> dmraid version:		1.0.0.rc16 (2009.09.16) shared 
> dmraid library version:	1.0.0.rc16 (2009.09.16)
> device-mapper version:	4.17.0
> It appears that some change you made to the newer version broke it with respect to my system.  Can you fix it?  Or, in the alternative, can you tell me how to install the older version so that I can get dmraid to work with Maverick?

Can you please send the output of "dmraid -rD"?
See "man dmraid" for details.

Meanwhile you can ask Ubuntu guys how to downgrade on that distribution.
You need to rebuild you initramfs after that, because is likely
activates your RAID set and needs to receive the downgraded dmraid
binary as well.


> Thanks for your help.
> Joe

More information about the Ataraid-list mailing list