Rescue CDROM

Willem van der Walt<> willem at
Fri Apr 30 06:44:12 UTC 2004

Martin, I think a message like this is one of those that, when googleing
one is very glad to find. You are waisting no one's time by sending it,
you are contributing to solving other's problems.
Another way to get to the point you were trying to get to would be
to use a redhat 8 cd.
It contains speakup in the kernel and can be made to go into rescue mode
when booting. An even easyer way might be to boot with
oralux and go to a command prompt. People must correct me if i am wrong 
but i think one can do that.
Regards, Willem

On Thu, 29 Apr 2004, Martin McCormick wrote:

> 	I am happy to report that I got the system back, but not
> without a fight.  I burned the jupiter.iso CD and then re-discovered
> that the system in question had the wrong boot order setup in the
> BIOS.  After I got someone to help me rearrange the boot order for the
> dead system, the jupiter disk booted just fine but I couldn't seem to
> get the serial port to talk to me or rather get it to send data to my
> old P.C. with DOS and the screen reader.
> 	The jupiter disk sounds like a really neat system that I
> should learn more about, so I will mess with that more later, but I
> still needed a shell I could run to try to recover this Linux system I
> had broken so well.
> 	I remembered that the Linux installation CD's have a shell one
> can run so I tried that once again.
> 	For those on the list who want to install Linux via CDROM, you
> can get a serial console going by booting from the CD, waiting for
> your disk to stop spinning, and then typing the following line without
> hitting any other keys:
> linux console=/dev/ttyS0 9600,n,8,1
> And your speech synthesizer terminal should come to life a few seconds
> later.
> 	Anyway, I did that and got the Linux opening screen.  After
> you get the opening message, you should hit r instead of choosing any
> of the installation options.  That gives you a new menu in which one
> of the choices is to run a shell.
> 	I ran the shell and tried to mount the primary boot partition.
> This is the one I had accidentally tried to set up as swap.
> 	The system wouldn't let me mount it to save my soul.  Mount
> kept giving me the error that I was using an invalid argument.
> 	The rescue system on the Debian CD I was using didn't have
> fsck or vi.  It has an editor called nano which is small enough to fit
> on a floppy.  If you like using strange editors on the most critical
> files in your system which is already hurting, then go for it.  I
> personally would like to have an environment that is somewhat familiar
> to me so I can hope not to tear things up any worse than they already
> are.
> 	As a long shot, I went to my good working Linux system and
> built a floppy containing just vi and fsck which I then put on the
> broken system.
> 	Vi wouldn't work because it needed different shared libraries
> than were on the CD.  fsck, however, worked fine and I found out that
> when I had set the wrong swap partition with mkswap, I had
> effectively dismounted my / file system without syncing it.  That's
> what really messed up the world.
> 	After running fsck and allowing it to restore all the right
> block counts, it mounted like it should and I could see that fstab
> hadn't been corrupted after all.
> 	The system booted and all is well now.
> 	I am wasting everyone's time on this list describing what
> happened because you will all probably get yourselves in to a jam like
> this somewhere along the way.  I was about ready to just give up and
> re-install everything, but my laziness kept me hoping for a shorter
> path and it worked out.
> 	When things are broken, the serial console is really our
> friend if we can find some way to use a talking terminal.  It goes
> without saying that my example above of how to activate the serial
> console should be modified to fit your particular system so if your
> only working serial port is /dev/ttyS1 or something like that, you put
> that in to the device part of the command.
> 	Also, the mkswap command fortunately did not change the
> partition types although I have no idea what it might do if you
> specified more parameters other than the partition name.  One of you
> can try that and tell us how it went.
> 	If you upgrade a kernel from 2.4x to 2.6, you have to run
> mkswap -v1 on your swap partition to make the kernel happy.  That's
> how I got this whole mess started.
> Martin McCormick WB5AGZ  Stillwater, OK 
> OSU Information Technology Division Network Operations Group
> Karl Dahlke writes:
> >
> >Scroll down to the bottom of the page.
> >You will find the cd image and documentation.
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at

More information about the Blinux-list mailing list