boot cd for Fedora Core 3

Nath at
Sat Nov 20 21:40:07 UTC 2004

Dave Mielke <dave at> writes:

> [quoted lines by Nath on 2004/11/20 at 11:22 +0100]
>>First I grabbed the braillified installer and boot from the cd. At boot
>>prompt I typed :
>>text brltty=pm,usb:
>>Unfortunatly no braille appeared on my braille display, brltty was not
>>loaded at all since I didn't hear any brltty's beeps.
> I don't hear any beeps either, but brltty does start. The lack of beeps in the
> installer is probably similar to the fact that you don't hear beeps either once
> FC3 is booted. The reason is that the kernel module pcspkr needs to be
> modprobed in order for beeps to work, and because they don't do that by
> default.
>>So I decided to make the Fc3 disk 1 with the rhmkiso script from svn
>>repository but no luck it seems it requires a e2fsck version newer than
>>the one which is installed on my Debian sarge system. I have the 1.35
>>version (february 2004).
> That turned out to be a problem even for FC2 users, although I didn't realize
> it until after having posted that message. A subsequent update to rhmkiso deals
> with that problem as well.
Ok, I just update my copy of rhmkiso from the svn repository and I'm
actually trying to build the iso again with this new version. I had the
message "updated to revision 1210".
I'll let
you know the results.
>>Do you think it doesn't  work because my braille display is an usb
>>braille display ?
> Just now, i.e. immediately before writing this reply, I wrote the brlfc3i.iso
> image from BRLTTY's download page to a CD and tested it. It works for me for
> both serial and USB devices.
I gunzipped the initrd.img file contained in the brlfc3i.iso file and
see that the usb devices (/dev/ttyUSB0 etc ...) are not present on the
file system. also no /dev/vcsa0 device. 
So perhaps the Voyager doesn't need /dev/ttyUSB0 and the Papenmeier
needs it ? i don't know. 
Also I tried to understand how the brltty executable is started but it
seems things have changed compared to the RH boot diskettes : In fact I
see an init file but not an init_real file. 

>>As sommeone ever successfully got braille support with this braillified
>>Fc3 installer ? 
> As the maintainer of a project, users usually only get in touch with me when
> they have problems. I rarely ever hear about successes. :-) That's okay though,
> as that's why I'm here.
Promise : I let you know even if I succeed finally :-)
>>and particularly if you have a Papenmeier BRAILLEX EL40S?
> No. I used a Papenmeier BrailleX 2D for serial testing, and a Voyager for USB
> testing.
>>Of course Dave i think you successfully started with this iso and
>>braille support ?
> Actually, today was the first time I tested it for myself. I knew it'd work
> though, so I wasn't worried.
>>The brltty's version included is the 3.6 ?
> Yes, 3.6 is in the installer image.

so as I told before I tried to make the entire disk1 with the new
rhmkiso you commited today and in the same time I write this message the
process of making the image terminated and unfortunatly with the same
e2fsck as before. Here is exactly what message I obtain on the console :

/tmp/rhmkiso.YPaq0m/brltty-3.6/Programs/sys_shlib_dlfcn.h:27: warning:
Using 'dlopen' in statically linked applications requires at runtime the shared
libraries from the glibc version used for linking
sys_linux.o(.text+0x116): In function `loadSharedObject':
/tmp/rhmkiso.YPaq0m/brltty-3.6/Programs/sys_shlib_dlfcn.h:27: warning:
Using 'dlopen' in statically linked applications requires at runtime the shared
libraries from the glibc version used for linking
954+0 enregistrements lus.
954+0 enregistrements écrits.
976896 bytes transferred in 0,371744 seconds (2627873 bytes/sec)
e2fsck 1.35 (28-Feb-2004)
e2fsck: Filesystem has unsupported feature(s)
e2fsck: Veuillez obtenir une version plus récente de e2fsck!

so, a lot of warnings (I only copied the two last) following by the
error message.

> -- 
> Dave Mielke           | 2213 Fox Crescent | I believe that the Bible is the
> Phone: 1-613-726-0014 | Ottawa, Ontario   | Word of God. Please contact me
> EMail: dave at | Canada  K2A 1H7   | if you're concerned about Hell.
>                   |
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at


More information about the Blinux-list mailing list