iptables (Re: Connection Refused on ssh)

John J. Boyer director at chpi.org
Sat Oct 9 08:36:44 UTC 2004


That worked! I always knew you were pretty smart. The source machine is 
indeed a new Debian install on the new computer. The target machine is my 
old Redhat install on an old computer. I want to use that machine to 
receive mail, for backups, etc.

Thanks to everyone who helped in solving this problem, especially to 


On Fri, 8 Oct 2004, Cheryl Homiak wrote:

> If this is your debian machine you are sshing from, it would be a new 
> installation and new computer, correct?
> Sorry if this has been covered before, but it seems to me that if there 
> are no authentication methods to try (I'm not sure whether you included 
> the part that showed what methods had been tried), there's a good chance 
> your password authentication is disabled in the RH machine's ssh_config or 
> sshd_config or somewhere. Otherwise, it should ask for your password once 
> all other 
> methods have been tried. can we assume you are the same user on both 
> machines--you're sshing as jboyer (or whatever) on one machine to the same 
> username on the other machine?
> I just went back and looked at your other posts, and the one that shows 
> your sshd config shows password authentication as no. Unless you changed 
> it, that's why you're not being prompted for a password. I believe that is 
> in both the ssh_config and the sshd_config so check both; I think the 
> debian machine's is usually set to yes by default but you might want to 
> check them too.
> Sorry if I missed a post and this has already been taken care of.

John J. Boyer; Executive Director, Chief Software Developer
Computers to Help People, Inc.
825 East Johnson; Madison, WI 53703

More information about the Blinux-list mailing list