Karl Wilbur karl at
Mon Sep 26 21:19:06 UTC 2005

Hart Larry wrote:
> Hi All:  We just installed windows-xp Home--and so grub was gone.  We 
> tried to install grub using by using the rescue cd. At the rescue 
> promopt we chrooted to /mnt/sysimage then tried grub-install /dev/sda 
> but this gave anerror message. 

No need to chroot.  I have done this procedure many, many (too many) times.

> also trying to do a fdisk -l gives an 
> error that cannot open/proc/partitions

DON'T FDISK! There is no need.

> gives error /usr/share/grub/i386-redhat/stage1: Not Found. before this 
> we tried running samba we got errors saying smbd failed trying to start 
> smb i tried using all the known samba startup commands and 
> scripts....all ofthis is on Fedora core 4. Any suggestions ???

Start rescue disk.

Run grub from the command line.

Tell grub which drive,partition to look at for it's menu.1st (grub.conf) 
boot (hd0,0)

Yours may not be hd0,0 so replace that with what ever you need for your 

Then tell grub where to install itself.  I suspect the you want to 
install on the mbr of you primary drive so you do:
setup (hd0)

But again, this may be a different location for your system so please 
keep that in mind.

Let's get the drive booting to grub before we tackle Samba.

Karl Wilbur

More information about the Blinux-list mailing list