make of flite stuck on kal 8k

Lukas Loehrer listaddr1 at
Thu Jun 29 08:39:03 UTC 2006


In my experience, you will need at least 512MB of physical memory to
compile flite in a reasonable amount of time. You can increase your
swap space to say 1GB, but because you only have 20 % of the physical
memory required, you will see terrible thrashing because a locality of
reference in a compiler like gcc is probably rather low. I tried to
compile flite once on a 256MV machine with 1GB swap space and stopped
the process after a few hours.

Flite 1.2 sounds better than flite 1.3 in my opinion. They managed to
decrease memory usage significantly in 1.3 but the price is some
decrease in voice quality I think. So, if you do not use it in a kind
of embedded device, I would recommend going with flite 1.2. Why can't
you use a precompiled package?

Best regards, Lukas

krishnakant Mane writes ("make of flite stuck on kal 8k"):
> hello all,
> has any one found problems building flite 1.3 on fedora core 4?
> I tried it yesterday and all went well untill make tried to build the
> files for kal 8k voice.  it can't go any further.  I have a 128 mb ram
> with 8 gb hdd space and amd duron based machine.
> the make of flite gives this problem and the prompt never returned (I
> waited for 2 hours ).  actually this problem has confused me because
> it is not throwing any error either!
> just gets stuck on the line that says that it is doing the build of
> kal 8k (can't remember exactly what is the line but all those gcc
> lines u know?)
> I had previously posted a thread regarding static voice with my vibra
> 128 sound kard which is still unsolved.
> actually it seams my card is being taken by alsa as sb16 bit.
> don't know how to get around this too!
> it is now becoming very urgent so please help.
> thanks.
> Krishnakant.
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at

More information about the Blinux-list mailing list