Building edbrowse on Debian

Martin McCormick martin at
Sun Jul 1 18:43:59 UTC 2007

I thought for a while I might get edbrowse-3.2.1 to build since
the README file mentions Debian, but I think we are running in
to the thing I call the orphan syndrome. So much stuff has
changed since the code was written that it is hard to find what
you need to safely build it.

On my Debian system, I needed to install libpcre-ocaml-dev
to get libpcre-development functionality. You can't really find
a libpcre package as such, but the one I did install quieted
things down and solved the first missing library problem. Then,
I hit the wall.

jsdom.c:13:19: jsapi.h: No such file or directory

	It gets a lot worse from there.

	I did manage to get the Mozzilla javascript library
mentioned in the edbrowse README file. The link to it is no good
any longer, but a google search turned up the fact that it is
still on the Mozzilla site but in a different directory.

	I got it and followed the directions in README which read:

>Expand this in /usr/local.
>It will create a directory js.
>Go into js/src and run
>gmake -f Makefile.ref

Another buzzer! gmake doesn't exist so I just tried make.

>This should build everything you need.

	Well, it kind of looked okay in that there were no

>cd Linux_All_DBG.OBJ
>ln -s `pwd`/ /usr/lib/

that's where I chickened out because there is already a file by
that mane. I had installed spidermonkey which is a Debian
package when building elinks so it is really there already and I
think that edbrowse found it since the first errors seem to be
related to things that aren't as they should be according to
what edbrowse is expecting. If I change the link, this will
more than likely break elinks next time it runs.

	Anyway, that's the health of edbrowse at this location.
It looks like a pretty neat thing if it can build.

Martin McCormick

More information about the Blinux-list mailing list