braillenote under linux

Dave Mielke dave at
Tue Jul 3 12:34:43 UTC 2007

[quoted lines by michaelweaver on 2007/07/03 at 12:15 +0100]

>I do not seem to be able to get Brailletty to start.
>I get an unable to open device or read device such and such followed by
>unable to read screen.
>The error message I get is something like:
>cannot open screen device: /dev/vcsa: permission dennied 
>brltty: unable to read screen

The error "permission denied" means that the device exists but that brltty
isn't allowed to access it. The most likely cause for this is that you're
invoking brltty as a normal user rather than as root.

>I typed brltty serial:ttyS0 and even tried just brltty but still get the
>same error messages.

You need to specify the device via the -d option. It's not just a positional
parameter. Specify it lke this: -d serial:ttyS0

Dave Mielke           | 2213 Fox Crescent | I believe that the Bible is the
Phone: 1-613-726-0014 | Ottawa, Ontario   | Word of God. Please contact me
EMail: dave at | Canada  K2A 1H7   | if you're concerned about Hell.                   |

More information about the Blinux-list mailing list