My experiences with a Mac

Tony Baechler tony at
Mon Mar 17 10:52:12 UTC 2008


OK, you make lots of points here so here goes.  Before I start, I would 
like to say a few things for clarification.  I don't own the Mac I'm 
working on, so I don't have the flexibility to randomly try too much 
except what's already installed or what's on the install DVD.  Second, 
the FN key is already turned off so I don't need to hold it for function 
keys.  I don't know if I did that or if VoiceOver does that 
automatically but somehow it got set that way.  Finally, I'm running 
version 10.5.2 of Mac OS X, a 2.2 GHZ core 2 processor and 2 GB of RAM.  
I forgot to talk about Spotlight or the calculator which I'll discuss below.

Benjamin Hawkes-Lewis wrote:
> Tony Baechler wrote:
>> I am guessing but I think it's based on OpenBSD.
> It's an independent flavour of BSD derived from NextStep:
I'll take your word for it, but everyone knows that wikipedia is the 
best and most accurate source of information out there. <grin>  
According to the FreeBSD folks, it's based on FreeBSD.  According to 
what I saw, it looked like OpenBSD but I've not actually used OpenBSD 
before.  Other sources say that it's derived from 4.4 BSD Lite and Apple 
wrote everything else themselves.

>> One area where the manual is wrong is where it says that you can hold 
>> down Control and Option and press the letter H for help on the 
>> current control. The manual says that most controls have help tags.  
>> Well, every time I tried that, I was told that there was no help for 
>> this control.  I've so far only used programs supplied with the OS.  
>> It has no equivalent of MSAA, browse, or forms mode for web pages.  
> Actually, it would be more accurate to say that it only has an 
> equivalent to MSAA, browser, or forms mode for web pages, but doesn't 
> treat form filling as a different mode. Rather than scraping a virtual 
> buffer from the tree of accessibility information, VoiceOver simply 
> presents the tree, form widgets, links, text and all.
Again, I'll take your word for it.  I only went by the manual's 
description of how to browse web pages.  I didn't have networking before 
and now I do so I'll try web browsing later.  No mention of filling out 
forms was discussed at all in the manual but I didn't read the entire 
chapter so perhaps I missed it.  I have not read the complete manual yet.

> > If there is a more complete manual besides the
>> getting started manual that I downloaded, it wasn't obvious.
> Well, that's actually a manual for an older version of VoiceOver from 
> OS X 10.5.2. I'd supplement that with VoiceOver's own on-board help.
Please elaborate.  I'm running 10.5.2.  What has changed?  I saw 
mentions of help but since that seems to be in html and browsing html 
pages looks difficult, I hadn't bothered thus far.  So far the manual 
seems to be mostly correct and I saw no what's new document.

>> There must be an easier way to get to installed applications, but so 
>> far the only way I found was to open the hard disk and arrow down to 
>> Applications.  
> I often just type the application's name into Spotlight and let OS X 
> find it for me.
Ah, Spotlight.  I forgot to talk about this earlier.  Yes, it's probably 
the easier method of running programs if you know what you're looking 
for.  It seems to be like the new Start Menu in Windows Vista.  You just 
type the name of what you want, such as "term" for Terminal, and it 
searches on the fly.  In my case, it showed 22 items.  The first was a 
dictionary definition for the word "term."  The second item was 
Terminal.  That is so far the only way I've found to quickly get to 
Terminal.  The drawback is that there is no way of seeing a list of all 
installed programs.  I didn't try just a wildcard character but I don't 
think that would work because that would match everything.  If there is 
an easier way to browse applications from Spotlight, I'm unfamiliar with 
it.  For a new user, it helps greatly as long as you have an idea what 
you're looking for.  I would have never found Chess with it for example 
because I didn't know it was there until I browsed the Applications 
table in the Finder.

>> Opening the Applications row in the table showing all hard disk 
>> directories is as close to the Windows start menu as you're going to 
>> get. 
> Have you been using OS X long enough to make such a definitive 
> statement? It's not clear what aspect of the Start menu you're missing.
No, I haven't.  I have not however found any other way to see all 
installed programs in a menu structure.  If I press the Windows key 
right now, I can arrow down to Programs or press the letter P.  From 
there, I can arrow through all the programs I've installed.  I saw no 
easy equivalent to this for the Mac except to use the desktop to open 
"Macintosh HD" and arrow down to Applications, expand, and arrow through 
about 90 different directories.  I certainly hope I'm wrong on this but 
the manual didn't give any other methods apart from Spotlight which I 
discussed above.

>> First, there was a dialogue that came up because the network wasn't 
>> set up correctly.  It never spoke that at all.  I had to have sighted 
>> help use the mouse to close the window.
> You can switch between windows with Apple Tab.
Nope, not in this case.  I tried that several times and it still never 
came up.  I had no idea it was there until I asked my sighted help to 
look at the "About this Mac" screen and he said he couldn't see it 
because the network dialogue was in the way.  I tried to close it myself 
but I never found it and it never read it.  If I could browse the full 
screen with the VO cursor, I could've closed it that way but there is 
apparently no way to do that.

>> Another problem is that there is a permanent menu bar on the screen 
>> but tapping Command or Option will not open it, unlike Windows.
> Control F2 will open the Apple menu, then you can press the arrow keys 
> to move between the menus. (Though you also need to press Fn on a 
> Macbook, since F2 is a secondary function of another key.)
Ah, I didn't know that.  Do the menus close automatically if you arrow 
past the right-most menu?

> >  One nice thing is that the Apple menuis always visible so you can 
> always get out of a program that locks up, at least in theory.
> Well, also Option Apple Escape will open a force quit menu, vaguely 
> similar to the Windows Task Manager.
You keep referring to the "Apple" key.  I think you mean Command.  The 
"Apple" key disappeared a long time ago according to what I've read.

>>  There are status menus also, such as for battery power and 
>> bluetooth.  It read all of those fine.  There is no other keyboard 
>> way to access them.  
> Control F8 (again with FN on a laptop) with get you straight to that 
> set of menus.
Again, this is not documented in the manual.

>> I would like to briefly discuss the terminal since it will be of 
>> interest to most of you reading.  As I said, it is based on BSD and 
>> has the basic utilities you would expect such as ls, bash, man, less, 
>> and nano.  It is missing other things that you would normally find 
>> though, such as there is no cc or gcc and no text browsers.  There is 
>> the standard ftp but no lftp or ncftp.
> This is true of the default installation. But you can install Apple's 
> XCode developer tools package for compiling and also either Fink or 
> Macports to install lots of other Unix software. I prefer Macports 
> myself. So, for example, I can just do:
> sudo port install lynx
> to grab lynx, and
> sudo port install ncftp
> to grab ncftp.
Yes, I stand corrected.  On the DVD, there is gcc 3.3 and 4.0.  There is 
also X11 and some other tools.  The problem with the above "sudo" 
command is that it still asks for a password and nothing I try works.  
I'm sure that sudo is the preferred way to do things but not without a 

>> My guess is that either you have to add a root user (but adduser and 
>> useradd didn't exist) or change everything via System Preferences.
> OS X has a root account disabled by default, like some other *nix 
> systems (e.g. Ubuntu does the same thing). You can enable it if 
> necessary:
> However, you can do pretty much everything with sudo if you're a user 
> with Administrator privileges, so I've never found any need to 
> activate root.
How do you determine this?  There is only one default user and 
apparently it doesn't have this.  The default user has no password.  
Does this need to be turned on or changed in System Preferences?

>> It has no concept of things like windows or graphic dictionaries and it 
> only shows
>> you the active window or dialogue, so it would be impossible for me 
>> to dismiss a background dialogue about the incorrect network settings 
>> because it would never read it.
> Do other screen readers interrupt to tell you that windows are popping 
> up in the background or something?
Yes, generally they do.  Even if they don't, I can look at the full 
screen with the mouse cursor and read it that way.

>> Again, I'll only have a week or so to play with it and experiment, so 
>> if you have any questions or things you want me to look at, please 
>> ask soon.  If this is considered off topic, sorry.  Please feel free 
>> to repost to other appropriate mailing lists.
> Well, this is a Linux list and OS X isn't Linux. However, here's at 
> least two more appropriate mailing lists for VoiceOver issues:
> They should be able to help out with some of your Terminal problems.

Thanks, but again I only have about a week so probably no point.  So 
far, I'm not impressed enough to buy one.

One thing I didn't discuss was the calculator.  Yes, it has one.  
However, you can't press numbers on the keyboard and get meaningful 
results.  You have to use the VO cursor to press buttons for each digit 
you want.  That means, for example, you have to use the left arrow to 
get to the digit 2, press Control, Option, Space, right arrow to 5, 
repeat the Control, Option, Space, right arrow a bunch of times to plus 
or times, press the button as described above, left arrow back to the 
number 2, press it, right arrow to 5, press that, and go all the way 
over to Equals.  All of this must be done while holding down Control and 
Option.  Then what happens?  Absolutely nothing.  That's right, the 
result is never spoken even though it appears on the screen.  Arrowing 
around will never read the answer.  I only found out that it showed an 
answer because I had sighted help.  That's the first time ever that I 
had an inaccessible calculator.  Please, someone tell me I'm wrong and 
it isn't as hard as all of this.  Someone tell me there is an easier way 
that I missed.  If I press numbers, I get no feedback at all in the 
calculator, which is why I resorted to the VO cursor.

As always, don't hesitate to ask about any specific things you want me 
to look at or try within the next week or so.  Thanks for your feedback.

More information about the Blinux-list mailing list