kernel selection failure follow up (fwd)

Jude DaShiell jdashiel at
Thu Sep 4 09:05:06 UTC 2008

---------- Forwarded message ----------
Date: Wed, 03 Sep 2008 18:18:00 -0500
From: Patrick J. Volkerding <volkerdi at>
To: Jude DaShiell <jdashiel at>
Subject: Re: kernel selection failure follow up

Hello Jude,

I know this feedback comes awfully late, but I wanted to thank you very much 
for continuing to give me reports on the problem that you had run into.  The 
installer's kernel script was rewritten some time ago to link or install the 
same kernel that was used for installation without the user selecting it from a 
menu like the last book shows.  The book is being revised, by the way.  At one 
time, this was tested and found to work.  However, I believe it may have broken 
when PXE installation support was added.  After examining the script for a long 
time today, I realized that $TMP was not globally defined, and was not defined 
anywhere in the kernel installation script, so it was unable to determine the 
device name for the CD drive.  Once I repaired that, the installer was able to 
ask for the first disc to fetch the speakup kernel and installed it properly.

It's possible that you've lost patience with Slackware, and if that's the case 
I can't say I blame you.  We do try hard, but this should certainly have been 
caught in Q/A for 12.1 and possibly 12.0 as well.  I am very sorry it did not 
work correctly.  But, looking at the positive side of things, I think I can say 
on behalf of all of the speakup users that you are owed a great deal of thanks. 
Now, the next set of CDs will install the proper kernel as they should.

Kindest regards,


Jude DaShiell wrote:
>  Hi Pat, I was the one that sent you email from jude.dashiell at
>  earlier this week.  I tried something with the slackware 12.0 disk set this
>  afternoon and when that failed I tossed the disk set in the trash. I tried
>  installing slackware using speakup.s so no packages would be installed from
>  disc2.  I wanted to find out if the kernel selection dialog would come up.
>  It didn't.  My guess is the system installed the boot kernel without asking
>  and attached the speakup parameters to it so when I hit control-alt-delete
>  to reboot I had myself a shiny new broken system. I don't know if this was a
>  disc defect or something more than that with the setup program itself.  This
>  system does not support booting from usb either so that wasn't and won't be
>  an option.  According to, the kernel selection dialog
>  should come just before the usb stick dialog.

More information about the Blinux-list mailing list