printing signs from command line

Jude DaShiell jdashiel at
Thu Jul 30 08:16:04 UTC 2009

I'm rather certain I'm still getting garbage out of the printer whenever 
connected to Linux but that same printer has worked correctly under dos. 
The thing that delayed me earlier this week was that the printer cord was 
plugged into the wrong computer.  Oddly when I booted the correct computer 
up with the printer attached, I got about four pages with a very little 
text on them printed out before the booting sequence had completed.  No 
idea what's going on with that.  Before I did the boot, I unplugged the 
printer from the power for a few seconds then plugged it back in again so 
just in case it had some bad memories these wouldn't interfere with work. 
Finally I found a mini-howto on the internet and tried the commands shown 
below but am still getting garbage printing out so far as I can tell..

Script started on Thu Jul 30 04:03:39 2009
d/Panasonic-KX-P1123-epson.ppdnic-KX-P-1123 -v parallel:/dev/lp0 -P /etc/cups/pp
localhost:~# cupsenable Panasonic-KX-P-1123
localhost:~# cupsaccept Panasonic-KX-P-1123
localhost:~# lpadmin -d Panasonic-KX-P-1123
localhost:~# lpadmin -p Panasonic-KX-P-1123 -c Impact
lpadmin: Printer Panasonic-KX-P-1123 is already a member of class Impact.
localhost:~# lpoptions -p Panasonic-KX-p-1123 -l
PageSize/Page Size: Custom *Letter A4 3x5 4x6 5x7 5x8 6x8 8x10 8x12 11x14 13x19 16x20 16x24 A3 Legal
PageRegion/PageRegion: Custom Letter A4 3x5 4x6 5x7 5x8 6x8 8x10 8x12 11x14 13x19 16x20 16x24 A3 Legal
Resolution/Resolution: *60x60dpi 60x72dpi 60x180dpi 60x216dpi 120x60dpi 120x72dpi 120x180dpi 120x216dpi 180x60dpi 180x72dpi 180x180dpi 180x216dpi 240x60dpi 240x72dpi 240x180dpi 240x216dpi 360x60dpi 360x72dpi 360x180dpi 360x216dpi
localhost:~# exit

Script done on Thu Jul 30 04:08:28 2009

More information about the Blinux-list mailing list