printing signs from command line

Jude DaShiell jdashiel at
Fri Jul 31 21:03:06 UTC 2009

I'm pretty sure some filtering failure may be allowing unicode to get to 
the printer directly.  I'm absolutely sure it's lp0 since there's only one 
parallel port on the machine and the printer runs when I send a 13 line 
text file out to it and prints about 8 pages of garbage.

On Thu, 30 Jul 2009, Terry Klarich wrote:

> Sorry for the slow reply.  Things have been pretty busy around here.
> Are you absolutely sure the printer is plugged into lpt1? you can cat a file to /dev/lp0 to be sure.  "cat /etc/issue > /dev/lp0.
> Your printer should do something.
> You might have to try /dev/lp1, /dev/lp2 and /dev/lp3.  I suspect it will be /dev/lp0 or /dev/lp1.
> Once, you have the device for your printer, I would start over and remove the class and printer you have created.
> lpadmin -x impact
> lpoptions -x Panasonic-KX-P1123
> lpadmin -x Panasonic-KX-P1123
> Now, make sure you have the correct ppd file placed in the /usr/share/cups/model directory.  It looks like the ppd file you
> downloaded is Panasonic-KX-P1123-epson.ppd.  You can examine this file.  The comments contained at the top will let you know for
> sure of the printer model.
> You don't need a printer class.  Printer classes are used to configure more than one printer to surve one location.  In a busy
> computer lab or some kind of printing shop, a class could be used to tie say 3 printers together in order to move those jobs
> through faster or provide redundence for printer failures.
> At this point, your printer queue should be totally gone.  This can be verified by:
> lpstat -p
> If you see some printers that you don't want, use the lpadmin -x and lpoptions -x commands to remove them.  I think you have to
> remove classes before printers can be removed.
> Now, it is time to create your printer queue.  Issue this command:
> lpadmin -p Panasonic-KX-P1123 -E -v parallel:/dev/lp0 -m Panasonic-KX-P1123-epson.ppd
> You should now have a properly configured printer queue.  I would check things out by:
> lpstat -p
> You should see your queue.  It should say that the queue is idle.
> If your printer is still not working, the problem has to be with the printer.  I think those old printers had several dipswitches.
> I'd find a way to verify these switches are in the factory default position.
> Let me know how it goes.
> Terry
> On Thu, 30 Jul 2009 04:16:04 -0400 (EDT)you write:
>> I'm rather certain I'm still getting garbage out of the printer whenever
>> connected to Linux but that same printer has worked correctly under dos.
>> The thing that delayed me earlier this week was that the printer cord was
>> plugged into the wrong computer.  Oddly when I booted the correct computer
>> up with the printer attached, I got about four pages with a very little
>> text on them printed out before the booting sequence had completed.  No
>> idea what's going on with that.  Before I did the boot, I unplugged the
>> printer from the power for a few seconds then plugged it back in again so
>> just in case it had some bad memories these wouldn't interfere with work.
>> Finally I found a mini-howto on the internet and tried the commands shown
>> below but am still getting garbage printing out so far as I can tell..
>> Script started on Thu Jul 30 04:03:39 2009
>> d/Panasonic-KX-P1123-epson.ppdnic-KX-P-1123 -v parallel:/dev/lp0 -P /etc/cups/pp
>> localhost:~# cupsenable Panasonic-KX-P-1123
>> localhost:~# cupsaccept Panasonic-KX-P-1123
>> localhost:~# lpadmin -d Panasonic-KX-P-1123
>> localhost:~# lpadmin -p Panasonic-KX-P-1123 -c Impact
>> lpadmin: Printer Panasonic-KX-P-1123 is already a member of class Impact.
>> localhost:~# lpoptions -p Panasonic-KX-p-1123 -l
>> PageSize/Page Size: Custom *Letter A4 3x5 4x6 5x7 5x8 6x8 8x10 8x12 11x14 13x19 16x20 16x24 A3 Legal
>> PageRegion/PageRegion: Custom Letter A4 3x5 4x6 5x7 5x8 6x8 8x10 8x12 11x14 13x19 16x20 16x24 A3 Legal
>> Resolution/Resolution: *60x60dpi 60x72dpi 60x180dpi 60x216dpi 120x60dpi 120x72dpi 120x180dpi 120x216dpi 180x60dpi 180x72dpi 180x18
>> 0dpi 180x216dpi 240x60dpi 240x72dpi 240x180dpi 240x216dpi 360x60dpi 360x72dpi 360x180dpi 360x216dpi
>> localhost:~# exit
>> exit
>> Script done on Thu Jul 30 04:08:28 2009
>> _______________________________________________
>> Blinux-list mailing list
>> Blinux-list at

More information about the Blinux-list mailing list