Strange, strange problem with google, lynx and brltty on one linux machine

Cheryl Homiak cahomiak at
Mon Apr 11 19:52:22 UTC 2011

This is a really strane problem. It doesn't appear to be a speakup problem and I can't figure out how it could be a brltty problem, so I'm trying this list.

First of all, I can load google fine using either fink's lynx or macports' lynx on my Mac.
On my linux machine, I can load google fine with elinks.
However, this is what is happening when I try to load google using lynx on my linux machine.
I have brltty running and it shows everything to "always allowing …" or even to "data transfer complete" and then the braillelite, which is on a serial port, seems to freeze there. If I change text consoles and then go back the braille will have updated and I can arrow down with braille showing where I am up to the "sign in" link and then it freezes again. The console itself is functional; I can quit lynx but the braille still doesn't update until I change consoles and change back. But if I quit lynx with ctrl-c, the braille updates immediately to the shell prompt.

However, this is not a problem of the website not loading all the way. If I also have speakup running, it lists the links and I can arrow to them and hit enter on them; once I go to a new page, I have full use of braille again but if I go back to the first google page, I can only arrow down to sign in and then it freezes once again. I've tried a bunch of different websites and it only seems to happen with google. In case I haven't been clear, I am using the text-based console. Does anybody have any idea what could be going on here?


May the words of my mouth
and the meditation of my heart
be acceptable to You, Lord,
my rock and my Redeemer.
(Psalm 19:14 HCSB)

More information about the Blinux-list mailing list