Strange, strange problem with google, lynx and brltty on one linux machine

Cheryl Homiak cahomiak at
Tue Apr 12 13:32:34 UTC 2011

This is getting stranger. I decided to try the google site in lynx as root which of course I wouldn't ordinarily do. Since I don't have the configuration modified for root, it asked me a couple of questions about accepting cookies; after I answered these, the website loaded and the console or data flow for brltty or whatever is frezing for me as a normal user didn't freeze. But it's still exhibiting the same strange behavior in any console as a normal user; I'm thinking it must be something that's gone temporarily awry in debian unstable but I have no idea what it is. So far, I've not had a problem with this behavior on any website other than google. I did try changing the cookie setting for a normal user to see what would happen; I was ble to answer the cookie questions but then I got the same frozen effect. but come to think of it, it can't be the console that's freezing because I can arrow down past the edit fields at the top and hit q and google and lynx close; so the website is loading and running fine but my braillelite doesn't give me the data. Btw I rooled back brltty with subversion to a revission before I had the problem and that didn't help so I don't think it's a brltty problem at all. Also, ctrl-C will also bring my braille display back to showing what's on the machine and working properly but sometimes I have to do it more than once.

my previous message:
This is a really strane problem. It doesn't appear to be a speakup problem and I can't figure out how it could be a brltty problem, so I'm trying this list.

First of all, I can load google fine using either fink's lynx or macports' lynx on my Mac.
On my linux machine, I can load google fine with elinks.
However, this is what is happening when I try to load google using lynx on my linux machine.
I have brltty running and it shows everything to "always allowing …" or even to "data transfer complete" and then the braillelite, which is on a serial port, seems to freeze there. If I change text consoles and then go back the braille will have updated and I can arrow down with braille showing where I am up to the "sign in" link and then it freezes again. The console itself is functional; I can quit lynx but the braille still doesn't update until I change consoles and change back. But if I quit lynx with ctrl-c, the braille updates immediately to the shell prompt.

However, this is not a problem of the website not loading all the way. If I also have speakup running, it lists the links and I can arrow to them and hit enter on them; once I go to a new page, I have full use of braille again but if I go back to the first google page, I can only arrow down to sign in and then it freezes once again. I've tried a bunch of different websites and it only seems to happen with google. In case I haven't been clear, I am using the text-based console. Does anybody have any idea what could be going on here?


May the words of my mouth
and the meditation of my heart
be acceptable to You, Lord,
my rock and my Redeemer.
(Psalm 19:14 HCSB)

More information about the Blinux-list mailing list