Pulseaudio and What I Found

Jude DaShiell jdashiel at shellworld.net
Thu May 17 02:27:14 UTC 2012

Pulse according to its documentation wasn't supposed to do this.  Thanks 
much for this information, I just couldn't figure out what to do about 
those alsa errors on login.On Wed, 16 May 2012, Martin McCormick wrote:

> 	I have had a Pentium 3 system for about a year and have
> been trying to get it to run some form of linux such as ubuntu
> or the latest version of Debian. It has been a battle from the
> get go. I haven't fixed the problem, but I finally found out
> what caused it.
> 	This system has a Dell ICH5 sound card and the chips on
> the mother board are about 2004 vintage with a 2.7 GHZ
> processor.
> 	The Debian testing distribution AKA wheezy is the first
> kernel to have speakup built in and I am happy to say it talks
> like it is supposed to.
> 	After installing wheezy with speakup, I noticed the
> system had tons of errors relating to alsa each time it came up.
> Also, if you tried to aplay, arecord or use mplayer on a file,
> really bad things always happened such as a spew of alsa-related
> errors stating the configuration file was corrupt topped off by
> loss of speakup again.
> 	I recently discovered, however, that if one was root,
> mplayer and aplay worked fine while speakup continued to work.
> 	This made me curious as to why root could use audio but
> users couldn't and it wasn't a permission problem.
> 	It seems that pulseaudio's daemon places a directory
> called .pulse in all users' directories. It populates .pulse
> with about 5 binary files dealing with pulseaudio configuration.
> 	On my system, something is terribly wrong with
> pulseaudio as the configuration files in .pulse poison any
> alsa-related tasks.
> 	Amixer, aplay and arecord all cause the spew of errors
> and no sound as well as no speakup afterward. If I remove the
> .pulse directory or those configuration files, audio works fine
> again.
> 	In a short time, pulseaudio restores .pulse to its
> poisonous configuration and we are back to square 1 again.
> 	For now, I installed pulseaudio's local configuration
> file known as client.conf in .pulse and told it not to autospawn
> which is one of the directives you can set.
> 	This seems to have stopped pulseaudio from re-building
> .pulse each time so I can use the command line and play audio
> but pulseaudio should be able to run using those configuration
> files and I believe that speech under gnome requires pulse so
> this is just a stop-gap measure until pulseaudio gets fixed.
> 	I think this bug has been around for awhile and may be
> due to pulseaudio not being able to handle that ich5 sound card
> otherwise everybody would not be able to use pulse.
> 	I admit I do not yet know much about pulseaudio and what
> it does but this discovery probably explains a good deal of why
> vinux, ubuntu and other recent linuxen haven't worked well on
> some systems regarding speech and sound.
> 	On the system in question, ubuntu9.10 would talk a
> little in gnome and then crash suddenly anywhere from a minute
> or so to maybe a few hours of operation.
> 	Ubuntu 10.x up to 12 and Vinux have yet to make a sound
> and I bet anything it is the pulseaudio situation. I imagine
> that if you have a sound card that pulse knows or likes better,
> everything is fine. I am posting this to see if anybody else can
> shed any more light or explain more what pulse does besides
> thoroughly trash the system's audio. It looks like it can be a
> very useful system when it works right.
> Martin McCormick
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at redhat.com
> https://www.redhat.com/mailman/listinfo/blinux-list

Jude <jdashiel-at-shellworld-dot-net>

More information about the Blinux-list mailing list