linux and floppy drive

Tony Baechler tony at
Fri Oct 5 09:45:35 UTC 2012

OK, that still doesn't answer my questions.  Do you have /dev/fd0 on your 
machine?  Did you install fdutils and see if it has a probe?  Does the dmesg 
output say anything about a floppy drive?  Does it let you mount known good 
disks?  It's highly likely that the disk you tried is old and won't format 
for whatever reason.  I've had brand new disks do similar things.  I think 
it's from sitting in a drawer too long.  What about formatting in DOS?  I 
see that fdutils has a command to make floppy devices if they don't exist. 
I don't know if udev handles /dev/fd0 or not, but that could be part of the 
problem.  Just as a guess, it sounds like either your disk or drive are bad, 
but it's hard to tell from only a couple formatting attempts.

On 10/5/2012 2:27 AM, Jude DaShiell wrote:
> I forgot:
> Script started on Fri 05 Oct 2012 05:25:01 AM EDT
> [root at hex29 ~]# fdmformat a:
> plain_io: Input/output error
> mformat: Error reading from '/dev/fd0', wrong parameters?
> [root at hex29 ~]# fdformat /dev/fd0 H1440
> fdformat: Could not determine current format type: No such device
> [root at hex29 ~]# exit
> exit
> Script done on Fri 05 Oct 2012 05:26:08 AM EDT

More information about the Blinux-list mailing list