Can I add speakup to An Existing Wheezy Installation?

Martin McCormick martin.m at
Mon Dec 5 17:32:33 UTC 2016

	Thank you. I am glad I asked because there is much less
to the procedure than I was expecting.

	The modprobe command worked fine as far as that there were no
errors reported. The apt-get install worked until the script
tried to start speakup and then the following happened: Output follows.

86audio3 martin ~ $sudo apt-get install espeakup
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 24.9 kB of archives.
After this operation, 90.1 kB of additional disk space will be used.
Get:1 wheezy/main espeakup i386 1:0.71-13 [24.9
Fetched 24.9 kB in 0s (71.7 kB/s)
Selecting previously unselected package espeakup.
(Reading database ... 124379 files and directories currently installed.)
Unpacking espeakup (from .../espeakup_1%3a0.71-13_i386.deb) ...
Processing triggers for man-db ...
Setting up espeakup (1:0.71-13) ...
[FAIL] Starting Speakup/espeak connector : espeakup failed!
invoke-rc.d: initscript espeakup, action "start" failed.
dpkg: error processing espeakup (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

	What I do know is that this system is a Dell Optiplex
from probably around 2000 or so and the on-board sound card is a
built-in cs4236 which works well with aplay, amixer and alsa in
general but has never been too eager to work with let's say,
ubuntu live CD's and other bootable CD's that talk on most
systems. This device shows up as card 0 and aplay -l and arecord
-l both produce good results so I may need to do some more
experimentation to see what else is wrong.

Again, thanks.

Martin McCormick

John G Heim <jheim at> writes:
> If you are using a stock debian kernel, you don't have to add speakup. You
> just have to load it. I am guessing though that you are asking how to load
> speakup, right? Well, that depends on which speech synth you are using. I
> am going to guess you want to use software speech, right? In that case, 
> you
> will have to add the espeak package. Here are the steps:
> 1. Type "modprobe speakup_soft"
> 2. Type "apt-get install espeakup"
> Your machine should start talking.
> technically not speakup.
> On 12/04/2016 01:16 PM, Martin McCormick wrote:
>             The subject is really the whole message. The wheezy
>     installation is on a system with 384 MB of ram so there is no
>     orca but I have seen speakup run on less although this is
>     scraping the bottom of the barrel.
>     Any good ideas are welcome. Thank you.
>     Martin McCormick WB5AGZ
>     _______________________________________________
>     Blinux-list mailing list
>     Blinux-list at
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at

More information about the Blinux-list mailing list