Raspberry pi's

Martin McCormick martin.m at suddenlink.net
Fri Dec 16 04:51:27 UTC 2016

	I decided to re-image my older Pi since the newer one
works and now the older board from 2015 talks just as well. I
also made another discovery. It appears that the raspberry pi
boards from this year or at least some of them now have a
built-in WiFi interface.

	I assigned static IP addresses for both the wired and
wireless interfaces on both Pi's and kept losing the newer board
which seemed to keep changing IP addresses almost randomly.

	Since the older pi needed a WiFi usb adapter, I had
ordered one for the new Pi. They are ten or fifteen Dollars if I
remember right so I never gave it much thought and put it in
before ever powering it up.

	It worked and i assumed it was the new adapter I had
plugged in until today when I unplugged it and the wired ethernet
cable to deliberately make it find nothing to get a network on.

	I listened to the bootup and it still said it had the
wireless address. I figured it was maybe remembering the last
good lease it got so I sort of laughed at it and tried to ssh
into another system and it did.

	ifconfig -a reports wln0 so I think the new adapter is
either doing nothing or occasionally becoming wln0. Well, I guess
I have a spare adapter now.

	Also, the old Macintosh keyboard works much better since
I ran rasp-config and told it to use a US-style keyboard.

	For any of you wanting to make the raspberry pi talk,
here are all the commands. I put a # infront of each line so
uncomment them all and then "source" the file from the pi user
account or any other account that has sudo capabilities.

#sudo apt-get install git
#git clone https://github.com/cromarty/ttsprojects.git
#cd ttsprojects/raspberry-pi/libilctts/src
#sudo make
#sudo make install
#cd ../../piespeakup
#sudo ./build.sh


More information about the Blinux-list mailing list