how do I find out what's hanging me up?

John G. Heim jheim at
Sat Jul 2 15:18:12 UTC 2016

When the kernel tries to kill a process or unmount a file system, it 
makes a system call which can result in something called an 
"uninterruptable sleep". Processes in an uninterruptable sleep state are 
marked with a D (I think) in the process table. You can see that with ps 
or top. Symptoms of a process in an uninterruptable sleep state are that 
if you do a df or an lsusb, it hangs and you can't even control-c out. 
There might be other ways to get the same result. But try doing a df and 
an lsusb before shutting down and it they hang, you know it's a kernel bug .

On 07/02/2016 03:54 AM, Mark Peveto wrote:
> Hi all,
> The short version of a long story.  I've just installed sonar on a dell pc.  I've also got it installed on a compaq/hp machine, where the followig
> problem doesn't exist.  On the dell, sudo reboot seems to hang.  Sudo shutdown works fine.  I've tried sudo shutdown -r now, sudo systemctl reboot, and
> other options.  How, without sighted help, can I find out what's causing this machine to hang when I reboot.  What's strange is this...why does it shut
> down just fine, but not reboot?
> Mark Peveto
> Registered Linux user number 600552
> Sent from sonar using alpine 2.20.13
> _______________________________________________
> Blinux-list mailing list
> Blinux-list at

More information about the Blinux-list mailing list