console speech

Alonzo Cuellar mariachiac at
Thu Jun 2 20:04:33 UTC 2016


I'll take it into concideration. the thing is I use gnome. However, if I 
can use alsa with gnome then I could have speakup and use espeakup via 
the console. There is an entry on the pulse wikki in Archlinux labeled

        ALSA/dmix without grabbing hardware device

Maybe I can use that. Or if gnome can run on alsa purely then that could 
probably be done.

I've never tinkered with this sort of thing. I believe I've tried a few 
times years ago, but i never got it to work and would lose speech. 
However, I didn't have a computer at the time to ssh into my system to 


*Note: *This section describes alternative configuration, which is 
generally *not* recommended.

On 06/02/2016 02:17 PM, Janina Sajka wrote:
> I've seen no stability issues with alsa, nor have I ever heard anyone
> complain of anything of the kind.
> Note also that Google adopted alsa along with the Linux kernel for Android. Note, further, that pulse depends on alsa. So, you wouldn't be getting stability with pulse, were also unstable.
> Janina
> Alonzo Cuellar writes:
>> Hi Janina
>> Yes... Pulse is not compatible with speakup. I do miss the console
>> environment. However, I've learned   to life with the desktop environment.
>> Since I've not tried using a pure alsa system in ages... I'm not sure how
>> stable it is. Pulse has been very stable in my experiences using the
>> desktop.
>> Alonzo
>> On 06/01/2016 08:58 AM, Janina Sajka wrote:
>>> Alonzo:
>>> If you're satisfied with working on the desktop alone, then you have
>>> pulse support in Speech-Dispatcher and Orca. But this thread was about
>>> console speech. I believe most of us who value the console environment
>>> have not found pulse compatible with Speakup--which is what most use on
>>> the console for a screen reader.
>>> Janina
>>> Alonzo Cuellar writes:
>>>> hello,
>>>> My thoughts. Pulse Audio has more functionality then Alsa. Alsa is great for
>>>> a low level system meaning only command line access. If you run a graphical
>>>> environment you will not be able to get discovery of sound automatically
>>>> unless of course you write some sort of scripts for Alsa.
>>>> I happen to think though that when Pulse Audio was beginning to be upon the
>>>> Linux community most of us who used Espeakup relied on Alsa heaviely. Now
>>>> its a bit of a problem for a user who wants the desktop experience.
>>>> Thats just what I see.
>>>> alonzo
>>>> On 05/26/2016 09:32 AM, Jude DaShiell wrote:
>>>>> Once pulseaudio is purged, try powering off the system then start the
>>>>> system up again and find out what happens.  If everything works, the
>>>>> system will reconfigure to account for the absence of pulseaudio and you
>>>>> should have speech back again once that happens.
>>>>> On Thu, 26 May 2016, Mark Peveto wrote:
>>>>>> Date: Thu, 26 May 2016 03:32:44
>>>>>> From: Mark Peveto <southernprince73 at>
>>>>>> Reply-To: Linux for blind general discussion <blinux-list at>
>>>>>> To: Linux for blind general discussion <blinux-list at>
>>>>>> Subject: Re: console speech
>>>>>> Tried, but it totally jacked up my sound after that.  I'm having to
>>>>>> reinstall again.
>>>>>> On 05/25/2016 01:58 PM, Jude DaShiell wrote:
>>>>>>> Mark has to get rid of pulseaudio and all of its dependencies.
>>>>>>> On Wed, 25 May 2016, Willem van der Walt wrote:
>>>>>>>> Date: Wed, 25 May 2016 14:10:06
>>>>>>>> From: Willem van der Walt <wvdwalt at>
>>>>>>>> Reply-To: Linux for blind general discussion <blinux-list at>
>>>>>>>> To: Linux for blind general discussion <blinux-list at>
>>>>>>>> Subject: Re: console speech
>>>>>>>> Get rid of pulseaudio.
>>>>>>>> You should be able to google how to do that on your distro.
>>>>>>>> HTH, Willem
>>>>>>>> On Wed, 25 May 2016, Mark Peveto wrote:
>>>>>>>>> I'm at my witt's end!  I'm working with f123, a manjaro
>>>>>>>>> based distro, and have had really good luck, until it
>>>>>>>>> comes to console speech using espeakup.
>>>>>>>>> It'll speak for about 30 seconds, then I get a
>>>>>>>>> pulseaudio error that looks like this.
>>>>>>>>> assirtion 'p' failed at pulse/simple.c:273, function
>>>>>>>>> pa_simple_write(). Aborting.
>>>>>>>>> It's shot me down on every manjaro based distro I've
>>>>>>>>> tried. Others have seemed to get speech in console, but
>>>>>>>>> I can't seem to make it happen. Vinux has
>>>>>>>>> it, and if i have to i'll put vinux on both machines,
>>>>>>>>> but that seems a little nuts.  I like vinux, and am
>>>>>>>>> using it now, but would also like the
>>>>>>>>> opportunity to work with these other distros.  I've been
>>>>>>>>> able to install my favorite programs, but trying to use
>>>>>>>>> them from a terminal just doesn't read
>>>>>>>>> well, so I need the console.
>>>>>>>>> Oh, and before someone says google it, I've done that
>>>>>>>>> for a week. Nothing helps.  LOL!
>>>>>>>>> Mark Peveto
>>>>>>>>> Registered Linux user number 600552
>>>>>>>>> Sent from vinux using alpine 2.20.10
>>>>>>>>> _______________________________________________
>>>>>>>>> Blinux-list mailing list
>>>>>>>>> Blinux-list at
>>>>>>>>> -- 
>>>>>>>>> This message is subject to the CSIR's copyright terms
>>>>>>>>> and conditions, e-mail legal notice, and implemented
>>>>>>>>> Open Document Format (ODF) standard.
>>>>>>>>> The full disclaimer details can be found at
>>>>>>>>> This message has been scanned for viruses and dangerous
>>>>>>>>> content by MailScanner,
>>>>>>>>> and is believed to be clean.
>>>>>>>>> Please consider the environment before printing this email.
>>>>>>>> _______________________________________________
>>>>>>>> Blinux-list mailing list
>>>>>>>> Blinux-list at
>>>> _______________________________________________
>>>> Blinux-list mailing list
>>>> Blinux-list at
>> _______________________________________________
>> Blinux-list mailing list
>> Blinux-list at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Blinux-list mailing list