[Testers wanted before the official release] Slint64-4.2.1 release candidate is accessible.

Linux for blind general discussion blinux-list at redhat.com
Tue Oct 10 20:04:43 UTC 2017

> The two slapt-getrc lines are identical unless there is a case difference I missed.

Yes my mistake, sorry, corrected in a further post that maybe you missed:
You do need to write slint-testing instead of slint-14.2, else the next
"slapt-get --upgrade" will actually downgrade your system to the
previous released version, that don't speak!

Also, I have edited the file
to mention the need to press [Enter] after booting.

Please let me know if anything is wrong, unclear, badly worded or missing:
English is a second language for me and I am not comfortable using it.

Proposals for enhancements are welcome.

> I have had success getting my wireless network up with nmtui.
> I went into the graphical environment and got to the cancel or launch screen of networkmanager but could only activate the cancel button but I think that's because I did not figure out what I discovered with nmtui yet.  With nmtui I edited connections and removed wired and then nmtui found my wireless connection easily.  I edited that connection and got to the cancel and OK buttons.  I couldn't get them working for a little bit until I used the right arrow key on the numberpad to move to ok and then hit enter.  After I did that and restarted the system I ran lynx and got to the lynx home page.  I suspect use of the right arrow on numberpad with numbers turned off will also work in networkmanager but haven't tried that yet.

So, at least nmtui is working. I will mention that somewhere.



> On Tue, 10 Oct 2017, Linux for blind general discussion wrote:
>> Date: Tue, 10 Oct 2017 07:49:53
>> From: Linux for blind general discussion <blinux-list at redhat.com>
>> To: blinux-list at redhat.com
>> Subject: Re: [Testers wanted before the official release] Slint64-4.2.1
>>     release candidate is accessible.
>> Hello,
>> thanks for testing.
>> Le 09/10/2017 ? 01:20, Linux for blind general discussion a ?crit :
>>> I have this version of slint installed and talking in console mode so
>>> far.
>> Good. Please report any issue.
>>> I'll test the graphical user interface after doing some post-install and getting slapt-get up and working.
>>> I need to testnetwork connection too. 
>> Well, indeed slapt-get's usage needs an active network connection.
>> Assuming a wired one, NetworkManager should work out of the box.
>> For a wireless one, I have only used the GUI applet yet, will try the
>> other tools to figure out which are accessible. But maybe you already
>> know that.
>> Then, for slapt-get to work with the right sources of packages you need
>> to tentatively edit as root the file /etc/slapt-get/slapt-getrc
>> modifying this line:
>> SOURCE=http://slackware.uk/slint/x86_64/slint-14.2/:PREFERRED
>> so it become
>> SOURCE=http://slackware.uk/slint/x86_64/slint-14.2/:PREFERRED
>> This is because Slint64-14.2.1 being not yet officially released its
>> packages are in a specific repository for at the moment.
>> Then just type as root:
>> slapt-get --add-keys
>> slapt-get -u # or slapt-get --update
>>> From time to time, run:
>> slapt-get -u
>> slapt-get --upgrade
>> the update notification icon of then panel being probably not
>> accessible. As usual to know more:
>> man slapt-get
>>> With slint, the dvd runs once installed for a while then stops.
>>> I hit enter once then slint found my speakers and in a little bit
>>> started talking.
>> Do you mean that when the bootloader is ready (after having rebooted
>> with the DVD inserted) you don't hear a beep? Maybe you machine doesn't
>> provide the "beep"?
>>> Once it was installed with lilo, I had to hit enter after boot for the
>>> system to come up and start talking.  This is for those that never
>>> installed a slackware system before so you know to not give up at
>>> those apparent stop points.
>> Yes, by default the system starts after a 2 minute delay unless set
>> otherwise in /etc/lilo.conf (and if EFI is used there is no time out at
>> all so pressing [Enter] is mandatory to boot).
>> Maybe I should reduce this delay when using lilo to 10 or 15 seconds?
>> Thanks for pointing this out. I will mention that in this file:
>> http://slackware.uk/slint/x86_64/slint-testing/iso/ACCESSIBILITY
>> Great having accessible slackware back and more accessible than original
>> slackware ended up being since slint works with sound cards for speech.
>> Thanks for the encouragement and please give feedback about speech
>> in graphical environments when you can.
>> Cheers,
>> Didier Spaier
>> _______________________________________________
>> Blinux-list mailing list
>> Blinux-list at redhat.com
>> https://www.redhat.com/mailman/listinfo/blinux-list

More information about the Blinux-list mailing list