DBus: Upgrade or Not

Linux for blind general discussion blinux-list at redhat.com
Sun Dec 30 19:21:04 UTC 2018

Ubuntu-mate 18.04 is the environment
I was wanting to install the Fenrir screen reader:
sudo pip3 install fenrir-screenreader
Pip then whined about DBus package requirement not being met.
  configure: error: Package requirements (dbus-1 >= 1.8) were not met:
dpkg -l | grep dbus
reports dbus is 1.12.2
Now, dbus is a means by which daemons communicate with each other. I don't think I can just grab the latest dbus package, build it and install it over the current one. That seems like a great way to break your system.
What are my choices here?

More information about the Blinux-list mailing list