Trouble Updating WordPress

Linux for blind general discussion blinux-list at
Thu Jan 18 10:31:20 UTC 2018

Hi, all.

Okay, before I get into the problem, I will outline everything that I 
tried in terms of troubleshooting.

I learned about how file permissions and ownership worked i.e. 4=read, 
2=write, and 1=execute. By adding these up you can get 0, 3, 5 and 7. 
The first number is special permissions, 4=setuid, 2=setgid, and 

First number is special permissions, second number is owner, third 
number is group, and fourth number is everyone else.

I set everything recursively to www-data in /var/www/html but the blog 
inside /html.

A while back, someone told me to include this line of code in the 
wp-config.php. define ('FS_METHOD','direct');

That allowed me to update plug-ins and stuff without problems. Then, a 
few hours ago I found some new combinations that were deemed safer.

cd /var/www/html/blog

sudo find . -type d -exec chmod 0755 {} +

sudo find . -type f -exec chmod 0644 {} +

I just tried installing a WordPress update, but after it unpacks it, it 
says, cannot create directory, installation failed. Thank you for 
creating with WordPress.

I also tried including this line below the define fs_method. 

That caused the whole WordPress site to crash.

What else should I try? Should I go back to using 7777? I don't want to 
have to unless that's the only way.

Many thanks in advance.



More information about the Blinux-list mailing list