slint audacious and cclive

Linux for blind general discussion blinux-list at
Tue May 15 12:10:45 UTC 2018

You have packages installed form the slackonly repo which are not at the
same version as those in the salix repo.

They are also built using SlackBuilds provided by but
for a more recent version than those on the salix "extra" repository
on which most pacakage are for a verion frozen some time after the
release of Slackware-14.2.

The rationale for this freeze is in this post from George Vlahavas, who
already added libquvi-scripts to the deps of cclive as I requested, by
the way:

Mixing repos can lead to such incompatibilities, so do this as root:

removepkg cclive libquvi libquvi-scripts

Then remove or at least comment out the SOURCE line for the repo in /etc/slapt-get/slapt-getrc
then run as root:
slapt-get -u
slapt-get -i cclive
This should download and install the three packages from
the salix (extra) repository

I confirm that cclive
works here.

PS Instead of removing the packages from slackonly you could just
run "slapt-get --upgrade" after "slapt-get -u" as slept-get should then
automatically replace them by their version in the salix extra repo.

Didier Spaier

Le 15/05/2018 à 13:31, Linux for blind general discussion a écrit :
> Okay, I got audionoir playing with the .vlc url.  However cclive is not
> yet working.  Once downloaded do I need to update library inclusions in
> /etc?  Some file in there has a list of libraries in it the system won't
> find unless they get mentioned in that file.  Here's a typescript file
> so you know what's happening on this end.
> Cut here.
> Script started on Tue 15 May 2018 07:25:48 AM EDT
> bash: ..: command not found
> internet is down
> bash: xport: command not found
> bash: td: command not found
> The Moon is New
> The Moon is New
> jude[~]$ sudo -i slapt-get --search quivvi
> libquvi-0.4.1-x86_64-2salix [inst=no]: libquvi (media-parsing library)
> libquvi-0.9.4-x86_64-1_slonly [inst=yes]: libquvi (media-parsing library)
> libquvi-scripts-0.4.21-x86_64-1salix [inst=no]: libquvi-scripts (Lua scripts for libquvi)
> libquvi-scripts-0.9.20131130-x86_64-1_slonly [inst=yes]: libquvi-scripts (Lua scripts for libquvi)
> quvi-0.4.2-x86_64-1salix [inst=no]: quvi (video download link parser)
> quvi-0.9.5-x86_64-2_slonly [inst=yes]: quvi (video download link parser)
> jude[~]$ which cclive
> /usr/bin/cclive
> jude[~]$ cclive
> cclive: error while loading shared libraries: cannot open shared object file: No such file or directory
> jude[~]$ exit
> exit
> Script done on Tue 15 May 2018 07:26:51 AM EDT
> On Tue, 15 May 2018, Linux for
> blind general discussion wrote:
>> Date: Tue, 15 May 2018 03:45:28
>> From: Linux for blind general discussion <blinux-list at>
>> To: Linux for blind general discussion <blinux-list at>
>> Subject: Re: slint audacious and cclive
>> Try
>> I ought to have checked for the vlc url but it's real uncommon to find
>> one of those on a web page.  Good news though in this case!
>> On Mon, 14 May 2018, Linux for blind general discussion wrote:
>>> Date: Mon, 14 May 2018 17:42:52
>>> From: Linux for blind general discussion <blinux-list at>
>>> To: blinux-list at
>>> Subject: Re: slint audacious and cclive
>>> Hello,
>>> Didier Spaier here,
>>> Le 14/05/2018 ? 22:10, Linux for blind general discussion a ?crit?:
>>>> on slint, I was able to install cclive and libquvi which is an undeclared
>>>> dependency but was not able to find liblua in slapt-get or spi so cclive
>>>> cannot be used.
>>> Actually if you type as root
>>> spi -i cclive
>>> it does download and install libquvi, so this is a declared dependency.
>>> About liblua, actually the package is named libquvi-scripts, so do this:
>>> spi -i libquvi-scripts
>>> I will ask George Vlahavas, who maintains the repository that stores
>>> these packages:
>>> to add libquvi-scripts to the cclive .dep file.
>>>> The audacious package throws a huge dbus error and I'd have a typescript
>>>> for you if keyboard commands worked once the -H option was used on the
>>>> command line for headless operation.  So far as I can tell none of them
>>>> work.
>>> Do you get this dbus error playing some file you downloaded?
>>> If you give me an URL to it I will try.
>>>> I have audacious playing a stream neither mplayer or vlc can play from the
>>>> website.  The mplayer program complains about dangerous
>>>> playlists and when I allow it to parse the playlist bombs out with some
>>>> other errors about indexing I've never heard from mplayer before as well
>>>> as a complaint about not being able to find a stream.
>>> To investigate further I'd need the URL of the stream you tried.
>>> But is the only stream
>>> provided by for a player working on Linux as
>>> others listed are for Winamp, iTubes player, Windows Media Player
>>> Real One Player and Quick Time Player are found in other OS
>>>> The vlc player can't even handle this stream either.
>>> It can here (listening now). Try thiscvlc
>>> Greetings,
>>> Didier
>>> _______________________________________________
>>> Blinux-list mailing list
>>> Blinux-list at

More information about the Blinux-list mailing list