w3m continues Edbrowse?

Linux for blind general discussion blinux-list at redhat.com
Tue Oct 30 10:53:39 UTC 2018

Okay, clearly, I'm doing something wrong or w3m is seriously broken.

executing w3m without command line arguments just prints its help
message. Piping this to a file so I can read all of it makes it clear
that a URL or filename is the minimal amount of arguments needed, but

w3m gmail.google.com


w3m relative/path/to/local/textfile.txt

produce completely blank screens. Shift H and Shift U as Schoepp
mentioned for accessing the internal help system and address bar do
nothing, and shift Q to quit seems to work only about half the time,
and I've more than once had to use control z to send w3m to the
bakground and exit twice to kill the background process.

As most of the installed packages on my system are sourced from Debian
Unstable(which provides w3m, and broken packages
occasionally find their way into Unstable, I tried downgrading to the
version from Debian Stable(, but this resulted in no change
in behavior.

Tab completion on w3m revealed the presence of the w3mman command,
which I assume is a short cut to w3m's built-in help, but executing
this command again produces a blank screen.

So, any idea what's going wrong here and how to fix it? W3m's
proponents make it sound like it has some nice features that make it
easier to use than other text-mode browser, especially for those
coming from a graphical browser, but while I haven't been impressed
with lynx the cat or what I've tried of links the chain and its
relatives, and browsh's dependence on Firefox means it'll never have
the small footprint that is usually a selling point of text browsers,
at least I can actually get web pages to load in those browsers.


Jeffery Wright
Bachelor of Computer Science
President Emeritus, Nu Nu Chapter, Phi Theta Kappa.

More information about the Blinux-list mailing list